EA Forums - Banner

Support Weapons Will Not Upgrade (Vet Server 5)

On Veteran Server 5 players are unable to upgrade Support Weapons. Can someone please check into this?
Blessings,
Daast

Replies

  • EE_Elephterion
    1546 posts Envision Developer
    edited January 2018
    Hello Commander,

    thanks for the heads up. We are aware and we will look into this. :)
    For clarification: you can't upgrade the support weapons on Vet5 AT ALL or only just to a certain point? And does it happen only on specific Support Weapons or on all of them, for both factions?
    Envision Entertainment Community Liaison
  • Lucyli753
    74 posts Senior Moderator
    Hey @XDaast ,
    thanks for the report, we`ll have a look at this! :)
  • Hello Commander,

    thanks for the heads up. We are aware and we will look into this. :)
    For clarification: you can't upgrade the support weapons on Vet5 AT ALL or only just to a certain point? And does it happen only on specific Support Weapons or on all of them, for both factions?

    No support weapons will upgrade for NOD. I am unsure about GDI. When you attempt to upgrade it flashes and stays lvl 45 then for a moment will change to 46 then back to 45 again. This is happening to multiple players.
  • GDI players cannot upgrade either. Thanks for looking into this.
  • Ok Commanders,
    I received words that there is a fix for this included in the next update that will roll out on Feb. 6-.7. Sorry for the inconvenience so far.

    If the issue still persists after that please report back :)
    Envision Entertainment Community Liaison
  • Ok Commanders,
    I received words that there is a fix for this included in the next update that will roll out on Feb. 6-.7. Sorry for the inconvenience so far.

    If the issue still persists after that please report back :)

    Thanks Eleph... Let's hope there aren't any wars that start between now and then.
  • XDaast wrote: »
    Ok Commanders,
    I received words that there is a fix for this included in the next update that will roll out on Feb. 6-.7. Sorry for the inconvenience so far.

    If the issue still persists after that please report back :)

    Thanks Eleph... Let's hope there aren't any wars that start between now and then.

    Same problem on 'Tiberian 32'. Hope the update will fix it here too.
  • gamerdruid
    3584 posts Moderator
    Yes - the update when it is rolled out will apply to all worlds.
    I am not an employee of EA/Envision. The views expressed are my own!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!