EA Forums - Banner

Scripts updated for 19.3

Replies

  • Je ne comprend pas pourquoi la réparation automatique fonctionne sur chrome, mais pas sur firefox.
    I do not understand why auto repair works on chrome, but not on firefox.
  • tried to add the basescanner fix as above. got error code as follows;
    line:1510
    Char:3
    Error: 'console' is undefined
    code:800A1391
    Source: Microsoft jscript runtime error
  • nefrontheone
    328 posts Member
    edited August 25
    Let's see, I didn't explain it because it's something that they explained to me for a long time but the new players may not know:
    Installation process:
    1) TamperMonkey for Chrome/firefox or GreaseMonkey for Firefox
    2) Wrapper
    3) MaelstromTools
    4) BaseScanner

    Note: These versions (in this thread) of the scripts are for game version 19.3

    Edited
    Note2: If you have previously some other script version or script package remember to deactivate the previous or earlier versions before install new scripts.
    Post edited by nefrontheone on
    Not a part of EA / Envision teams - My comments are only mine.
  • tried to add the basescanner fix as above. got error code as follows;
    line:1510
    Char:3
    Error: 'console' is undefined
    code:800A1391
    Source: Microsoft jscript runtime error

    You need to install TamperMonkey and then install scripts by clicking on the link
    AlkalyneD4, cnc-map.com/ccta-stats.com developer
  • same runtime error here, had updated java, deaktivated antivir prog, cleaned browser cache, but nothing worked
  • Hi! Does anyone has a script that shows "Next MCV" ? RP & money... Thanks!
  • Hi! Does anyone has a script that shows "Next MCV" ? RP & money... Thanks!

    Like this https://prnt.sc/oxfndp ?
    It's part of MaelstromTools.
    Not a part of EA / Envision teams - My comments are only mine.
  • I had something like that with "Center driven pack" https://prnt.sc/oxfs7x Now I have nothing! It's part of MaelstromTools? Is there an option to enable? Thanks!
  • Ok found it! Thanks! https://prnt.sc/oxg0p4
  • Ok found it! Thanks! https://prnt.sc/oxg0p4

    Yes, it's easy if you know https://prnt.sc/oxmr5f
    Not a part of EA / Envision teams - My comments are only mine.
  • I really miss because I do appear to select them: https://prnt.sc/owroyb

    Even changing the game's interface to French: https://prnt.sc/owrpqp

    Edited: I just checked that this error occurs with firefox, the captures I put are with Chrome.


    Pour ma part, j'ai toujours un problème avec la réparation automatique des bâtiments et des unités avec firefox.
    Je n'ai pas essayé avec chrome.
    For my part, I still have a problem with the automatic repair of buildings and units with firefox.
    I did not try with chrome.
  • I have no news that a solution has been found for the bug with firefox. Sorry.
    Not a part of EA / Envision teams - My comments are only mine.
  • AlkalyneD4
    42 posts Member
    edited August 27
    Do you use TA Autorepair that is included in Crucial Pack ?
    The one that allows you to choose repair order

    Here is the fixed script : https://github.com/SebHeuze/CnC_TA/raw/master/TA_Autorepair.user.js

    Note : I don't have any base to repair so I can just check that it load again correctly, I need someone who can test with a base to repair

    @nefrontheone can you update your first post with this link and the one for ReportStats in first page ?
    AlkalyneD4, cnc-map.com/ccta-stats.com developer
  • Christian17300
    29 posts Member
    edited August 27
    bonjour,
    Je ne comprend pas ce qui ce passe.
    Lorsque je veux avoir accès à la page d'accueil du jeu, je suis automatiquement connecté sur le dernier monde connecté.
    Je n'ai pas le temps de d'ouvrir la page de configuration du script.
    J'ai désactivé tous les scripts et cela ne change rien, je suis toujours automatiquement connecté sur le dernier monde visité.
    J'ai redémarré l'ordinateur et je n'ai pas d'amélioration.
    Je me suis déconnecté du compte, et cela recommence aussitôt que j'entre mon login et mot de passe.

    Je ne peux pas essayer le script auto réparation, il n’apparaît nulle part lorsque j'ouvre le serveur.

    PS : je passe sous chrome......

    Hello,
    I do not understand what's going on.
    When I want to have access to the homepage of the game, I am automatically connected to the last connected world.
    I do not have time to open the script configuration page.
    I have disabled all scripts and it does not change anything, I am always automatically connected to the last visited world.
    I restarted the computer and I have no improvement.
    I logged out of the account, and it starts again as soon as I enter my login and password.

    I can not try the auto repair script, it does not appear anywhere when I open the server.
  • Alors :
    Sous chrome, les deux cases d'auto-réparation sont toujours grisées, de même que sous Firefox.

    hxoapwokaogf.png

    J'ai raté un truc ?

    J'ai désactivé Base scanner puis installé le script corrigé séparément, ça fonctionne.
    Mais que faut-il désactiver dans le crucial pack pour avoir l'auto-réparation dans maelstrom tools ?

    So: Under chrome, the two self-repair boxes are still gray, as well as Firefox.
    I missed something?

    I disabled Base scanner then installed the script corrected separately, it works.
    But what to disable in the crucial pack to have self-repair in maelstrom tools?
  • de retour sur Firefox (puisque j'ai pas mieux sous chrome)...
    TA auto repair activé dans le crucial, mais je ne sais pas comment l'ouvrir en cours de jeu....

    Les cases auto-repair de maelstrom tools sont toujours grisée, pas de réparation automatique.
    Je pense qu'il faut attendre que les développeurs de scripts reviennent de vacance....

    back on Firefox (since I have no better under chrome) ...
    TA auto repair activated in the crucial, but I do not know how to open it during the game ....

    The auto-repair boxes in maelstrom tools are always grayed out, no auto repair.
    I think we have to wait until the script developers come back from vacation ....
  • nefrontheone
    328 posts Member
    edited August 27
    AlkalyneD4 wrote: »
    @nefrontheone can you update your first post with this link and the one for ReportStats in first page ?

    No, I don't. :-P

    Edited
    I can't see any button to access Autorepair but in console appears this info: https://prnt.sc/oy3pwl

    Same error if AutoRepair is deactivated (referred to some images, I think) - https://prnt.sc/oy3xed
    Post edited by nefrontheone on
    Not a part of EA / Envision teams - My comments are only mine.
  • AlkalyneD4
    42 posts Member
    edited August 27
    The autorepair button you see in Maestrom settings is different than the Autorepair script I fixed.
    So you don't need to enable it in Maestrom settings to have the autorepair if you have the script I fixed (same than TA Autorepair in Crucial pack but this one need to be disabled until Crucial pack update it),
    You should have now a repair button here :
    dzm8wyvayy58.png

    When you click on it :
    6ifj98jxyk50.png

    This autorepair is better since it allows to have a custom repair order and custom repair interval

    if the repair button and auto collect package in Maestrom are grayed out that's not a bug, it's because few years ago game developpers asked to remove these automated function in scripts. But everyone started to look for a custom version of Maestrom or another autorepair script

    @nefrontheone The error you have are just images that can't be found by the game, I think it's a problem with the game and not scripts ? or at least it should not be a game breaking bug
    AlkalyneD4, cnc-map.com/ccta-stats.com developer
  • nefrontheone
    328 posts Member
    edited August 27
    Ok, ok, I'll see now

    Edited
    With Chrome:
    Ha, ha, ha, I'm blind (maybe) - https://prnt.sc/oy4fg2
    Both option available but not activated at same time - https://prnt.sc/oy4gdu
    With firefox:
    https://prnt.sc/oy4ncp
    Not a part of EA / Envision teams - My comments are only mine.
  • gamerdruid
    2785 posts Moderator
    If someone mails me a set of links that work I can update the first post in this thread. I am on vacation so it may take some time, however, before I do it.
    I am not an employee of EA/Envision. The views expressed are my own!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!