EA Forums - Banner

Chrome "Not enough memory to open this page"

2Next

Replies

  • Sfaks
    4 posts New member
    Indeed you did! I was running 105 at the time I tested it first and did get one OOM but perhaps that was random as I do tend to have a lot of other tabs open and running. With 106 I have now had several sessions without any error so seems you are right.

    Thanks for all the help.
  • Update. The bug has been fixed and merged... it should be available at next chrome update. Let me know.
  • finally can go back to chrome, thanks for keeping track of this.
  • nefrontheone
    1013 posts Member
    edited October 2022
    Versión 106.0.5249.103 (Build oficial) (x86_64)

    The fail is active yet.

    Edited:

    54goueo8mvit.png

    In the middle of a battle. :-(
    Post edited by nefrontheone on
    Not a part of EA / Envision teams - My comments are only mine.
  • nefrontheone
    1013 posts Member
    edited October 2022
    A new version of Chrome has arrived, will it be the good one?

    Versión 106.0.5249.119 (Build oficial) (x86_64)

    Edited:

    Less errors but still presents:
    rtgoshipu4qh.png

    Post edited by nefrontheone on
    Not a part of EA / Envision teams - My comments are only mine.
  • Yes 106.0.5249.119 includes the fix for that bug. Let me know
  • nefrontheone
    1013 posts Member
    edited October 2022
    Like I said before, less fails but still failing. :-(
    And many time in the middle of a PvP combat. :-(

    Edited:
    If you have got a tab with your player and another tab with a substitution... if one of them crashes, both crashes at same time.
    But not the rest of your tabs.
    Post edited by nefrontheone on
    Not a part of EA / Envision teams - My comments are only mine.
  • I may have found a way to reproduce the out of memory bug. I wanted to see the moment it failed so I opened the Chrome task manager, forced it to stay on top (TurboTop) and kept an eye on it. Nothing interesting of course so I began tormenting the game. At first I just moved units around real fast; then I kept replaying sims back to back. These had some effect but I could only get it to eat up a meg of memory.Then I discovered that while replaying a sim if I held down the mouse button and just moved the mouse forward and back quickly moving from front to back of the base then the memory started shooting up like a rocked. I saw it go from 1M to 4M mem usage in 10 or 15 seconds. So that's one way to reproduce the bug. It appears to be a kind of runaway chain reaction. Something about garbage collection maybe? But, it's also happened a lot while the game is sitting idle, tab open but not user activity.
    I even tried setting Chrome to low priority in Win TM but to no avail.

    crackfed
  • gamerdruid
    4852 posts Moderator
    I can't comment on your findings, but I can confirm that the bug is still present when playing the game.
    I am not an employee of EA/Envision. The views expressed are my own!
  • well the fixed bug was related to garbage collection. I hoped it could fix the issue as they say they revert the browser behavior at 104 release. I think the only way go through is that game developers manage to look in the issue and reproduce the OOM, then probably open a bug on chromium or change the code in way the game does not cause the leakage.
  • This is interesting. The OOM crash can be reproduced with nothing more than mouse movement, not even clicking. Granted, you have to move the mouse pretty fast but memory use will build and reach critical mass pretty quick. I combined a speeded up mouse macro of a small circular pattern with my own manual movement which got it to crash in about 45 seconds. Seems like it peaked at about 5.8M, higher than before. Somebody tell the Chrome folks if they don't already know about this.

    Also, just a hunch, but something makes me wonder if there is any connection to Logitech drivers.

    crackfed
  • With Chrome version: 107.0.5304.110 (Build oficial) (arm64)
    The error still continues in Chrome.... :-(
    gmypx4g6lqsq.png

    Not a part of EA / Envision teams - My comments are only mine.
  • And the problem persist with Chrome in version: 108.0.5359.94 (Build oficial) (arm64)

    1kgjtm0c2ua2.png
    Not a part of EA / Envision teams - My comments are only mine.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.