EA Forums - Banner

"PLAY NOW" button not working

Prev1
As the topic says, the button isn't working: when I click on it, it just refreshes the main page but nothing else is happening.

Replies

  • Same here. Pathetic service.
  • Have that a couple of days now. Sometimes it works, sometimes not. Need to log off and on to check.
  • Me too! Since the May 7-8 "maintenance" days, I have been unable to start the game without trouble. The Play Now button simply redirects me back to www.tiberiumalliances.com/home and it refuses to start. I still can't use the Change Worlds function because it also ignores me and returns me to the /home screen. Even worse, the in-game World switching is also failing now because of an "unexpected script error" in Chrome that locks out the sidebar menu. If it isn't that problem, attempting to switch Worlds in-game dumps me back to the Home screen. The supposed fix to log out of EA, empty the browser cache, delete all cookies, close the browser and try again only works for a few hours, and then it's back to failing.

    I am also experiencing an increasing number of failed attacks, when clicking on the Attack button does nothing except eat my Command Points. I need to reload the game, and it's back to the runaround of trying to get past the /home screen.

    I'd say that someone at EA has Zynga'd the game, and it would be better to roll everything back to the way it was two months ago, before someone tried to fix what wasn't broken.
  • "I am also experiencing an increasing number of failed attacks, when clicking on the Attack button does nothing except eat my Command Points. I need to reload the game, and it's back to the runaround of trying to get past the /home screen."

    Had this problem too. But not having it lately. But hé, I can't check because I still can't play it. ;)
  • Hahaha I stopped playing this game 4 years ago because of things like this, just started back playing again and low and behold NOTHING HAS CHANGED !!!!

    I am sick of the lottery of whether or not the PLAY GAME button is going to work or not and as I only have certain times when I am able to play spending anything up to 30 mins doing this is not fun !!!!!

    Please just hire someone that actually has a clue **** they are doing !!!!
  • Same here, I have the same problem. Every time I click on the "Play Button" nothing happens and it keeps on going back to the main page. I noticed a lot of bugs after their last maintenance. So annoying!
  • Soixie
    572 posts Member
    No one cares
  • EE_Elephterion
    1857 posts Envision Developer
    @Splinter_Zeus if you are getting bounced back to the main page, are you displayed as logged in or still signed out. and is this on the first sign-in of the day or when you try to change accounts?
    Envision Entertainment Community Liaison
  • chaleomich
    1 posts New member
    @Elephterion you can say that first sign-in of the day. I am clicking for 2 hours, cant login.
  • Yes, I cannot log my other accounts online at the same time. Having a problem just logging on just as the first person stated .... just refreshes. World 22
  • Waylord7
    15 posts Member
    nice change world:
    my.jetscreenshot.com/26225/20180517-gegl-171kb.jpg
    And not working button "play now"
    this just refresh page.
    I cannot play 2 weeks properly.
    Nice game. Nice work.
  • I think they are protecting the developer, because they sure are not playing the game online. They would see the problems if they just play and changed accounts and worlds. Especially if they tried to log on with a second account in the same world.
  • Unbelievable that the issue with this button is still here, EA once had a great reputation but if you can't even fix a button than someone else who can should get your jobs.
  • this Message BELOW is a copy of an official reply from EA customer service and specialist who are looking into this exact problem. i have case number and all. please read this Detailed info that they claim will correct the problem.

    My name is JP and I am a specialist here at EA. I am currently looking into your case and first of all, let me apologise for any inconvenience caused and the length of time you have been waiting.

    The good news is that your case is now in my queue so I will be able to keep a close eye on it and will do my best to respond in a timely manner so you are not left waiting.

    So I can see here you are having issues after being a long term player with C&C Tiberium Alliances.

    I carefully read through your conversation with the previous advisor who has sent this to my department and I have been looking into this for you and my colleague who is an Expert for our other titles has informed me that any requests regarding Tiberium Alliances needs to be referred to this specific forum - https://forums.ea.com/en/commandandconquer

    I understand your frustration and also that you feel that no one cares about your issue but I have been informed that as long as you post on this forum that one of the moderators will reach out to you directly.

    Thank you again for your patience while waiting to hear back from us.we work on your issue George.
  • Do we know how long this play button issue will continue? Many of my alliance are fed up with it. If you want to do a quick bit of farming it makes it impossible. Having to keep coming back until you can get on is ruining the game. I was going to start the new server but I won't be doing so until this issue is fixed and it is stable again.
  • Come on guys. Get this fixed. It is still a problem. I cannot get on this evening. Same as every other evening. You must be losing a lot of revenue with people leaving because of this - as I will if you don't fix it.
  • EE_Elephterion
    1857 posts Envision Developer
    edited June 2018
    At the moment the best way to access the game is to use a direct link to the world you want to access. This only works after you signed in on the main page. Here is a collection of the frequently requested world links. If you are online a world you can just bookmark the world's URL.

    https://forums.ea.com/en/commandandconquer/discussion/221663/workaround-for-login-issues
    Envision Entertainment Community Liaison
  • OMG
    This is imbossible to play now
    Direct link to server redirect to main page
    Two month same problems and what happening
    U A FIRED
  • EE_Elephterion
    1857 posts Envision Developer
    Which world are you trying to access?
    Envision Entertainment Community Liaison
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.