EA Forums - Banner

WHAT WINTER CHALLENGE !!!!

I am on Tib 37 We have no knowledge of a running challenge as most worlds seem to be having
There was no Notification, one was starting or had started
All we got was Infection Base signs with no visual base
So as Far as Tib 37 goes there is no Challenge

Another Dev **** up you can not blame EA for this one
and like the problems at the start of 37 the players on there lose out again

Replies

  • Err0rChi7d26
    1 posts Member
    edited December 2018
    pk65drxa2mby.png
    I am on Tib 37 We have no knowledge of a running challenge as most worlds seem to be having
    There was no Notification, one was starting or had started
    All we got was Infection Base signs with no visual base
    So as Far as Tib 37 goes there is no Challenge

    Another Dev **** up you can not blame EA for this one
    and like the problems at the start of 37 the players on there lose out again
    Same thing happened on Tib 35.
  • methuselah
    412 posts Senior Moderator
    There was a challenge on every server to my knowledge. There was indeed some sort of graphical glitch that made the Camps "stealthed" if you will but beyond that it seemed to function, at least on my servers, the way other challenges functioned.

    The only thing I noticed, which is a very casual observation that could be explained by the graphical issue potentially was that the spawn rate of the infected camps seemed lighter than normal. I regularly had trouble finding infected camps to kill perhaps because they were invisible :wink:
  • On Wrath23 they're "stealthed" as well. When you sim one, you can't see all D-units and when you shift to see base, it all bleeds together. Not going to bother with this nonsense. Waste of time.
  • T35 the same problems, word infected but we couldnt see the targets and the attack just bleeds together as others said. When the challenge was over our screen said we failed and didnt get the rt reward nor did we get the achievement, I did on my other worlds but not on T35. The challenge is over, no sorry or any supplies to make up our loss.
    Glad we helped all servers finish the 2nd challenge even though we got nothing for it. Very SAD Christmas challenge, instead of Santa we got Scrooge.
  • methuselah wrote: »
    There was a challenge on every server to my knowledge. There was indeed some sort of graphical glitch that made the Camps "stealthed" if you will but beyond that it seemed to function, at least on my servers, the way other challenges functioned.

    The only thing I noticed, which is a very casual observation that could be explained by the graphical issue potentially was that the spawn rate of the infected camps seemed lighter than normal. I regularly had trouble finding infected camps to kill perhaps because they were invisible :wink:

    Eh? We had the announcement on t37 but then there was no counter or any other indication there was a challenge, I didn't see a single infected.
  • And Nothing will be Done as usual about it on the Worlds that it was Ballsed up on
  • I completely missed this and was mad because I missed out on the Legacy points for vet servers.....but after reading this and other threads I'm kind of glad I missed it now :P
  • methuselah
    412 posts Senior Moderator
    It was messed up on all worlds I'm pretty sure, I participated but it was frustrating that I won't argue. Maybe they'll run another one for us sooner rather than later once they figure out what the issue was.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!