EA Forums - Banner

Error on Purchase TA Funds on Tiberium 42

Tried purchasing additional TA bucks and get the error code 51003 everytime on every option.
Please check & fix when possible. Need funds real soon or I'll lose progress and my alliance too.

Thank you.


  • slappytrue
    1 posts New member
    Now this error is appearing on Tib 39 as of today for some reason! Hello EA support, you there? Knock, knock! Thank you
  • Hello Commander,

    what happened the last time you received the error? Do you receive the error within the game or on the Funds-Page?
    Envision Entertainment Community Liaison
  • Hello, same on Tib 37 today... on the Funds-Page...
  • gamerdruid
    5023 posts Moderator
    edited July 2020
    Which part of the world are you in and are your Origin country settings the same?

    After a little google research and a visit to answers.ea.com with a search for error code 51003 I have discovered some things that may help.

    The code is a one generated by Origin.
    Some players (of other games making purchases) have found by using Edge they can work around the problem. Some are also claiming the issue is with the browser and the use of Flash.

    My suggestion would be to try Edge to make the purchase.
    I am not an employee of EA/Envision. The views expressed are my own!
  • One thing is strange: I have two accounts on the same world (T37) with therefore two different email addresses. I can buy with the other (yveshlolo) but not with LOlopsw. And what also seems strange to me is that when I want to buy with LOlopsw, it is the Email address of yveshlolo that appears on the Fund page (and the yveshlolo profile) and not that of LOlopsw ... can -be a story of grouping together accounts? and yes, my country corresponds well to my profile. Well, I succeeded instantly, while staying on chrome: I left the wrong profile on the fund page and reconnected on it with the correct one, while remaining logged in to the game, and it worked. This came from opening the wrong profile on the fund page ... Thank you anyway for the help attempts, best regards ...
  • gamerdruid
    5023 posts Moderator
    It seems the problem with login and logging in that some have also have a knock on effect. Next time try logging out of the forum, and the game as well as completely out of Origin before you try to buy funds.

    The top right has a symbol of a head/shoulders and if you click on that you can see if you're signed in - if you are not it will give the sign in option.
    I am not an employee of EA/Envision. The views expressed are my own!
  • I could not buy from TA fund.
    With paypal everything goes normally, then when validating the command error 400 then error 10048.
    my 4 attempts appear on my account.
    With visa I have a message "impossible to order with this method of payment".
    I absolutely needed funds to buy pc and finish a fbase, in short big losses at the start of the server on tib47. chromium. these bugs tire me.
  • Hey paquif,

    in that case please reacht out to the EA payment support at: https://help.ea.com/en/contact-us/?product=cc-tiberium-alliances&platform=browser
    There then will be able to provide you the neccessary assistance.
  • Bundle purchase is not working anymore. Can this be please fixed ASAP?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.