EA Forums - Banner

Problems with payment

It is with the greatest of regret, I have decided to quit this game and along with it any game that EA has anything to do with. Today, I purchased funding for my account, however it credited an incorrect account.
Around 200 $ worth !. I reported the error to EA, they however told me to go jump in a lake . I have been playing Tiberium alliances for around 9 years and have spent many thousands of dollars over the years. Due to the glitches on their page, they stole my money. I disgusted and I am further considering legal action. The principal is important. Hang your head in shame EA


  • Can you please release my funds as I bought a package and it was approved by my credit card and am now waiting for you so I can get my funds. Help me please.
  • Just Tried to get Funds from SPAIN told try later. WHY do we keep having Fund Problems EA its been like this ALL DAY
  • gamerdruid
    4063 posts Moderator
    As regular visitors to this forum know, we can't resolve fund issues or produce solutions. @rturmelle you need to contact EA help, but first look in you origin account to see the purchase history. It should show there if there is a completed transaction.

    @TheSpanishRat1 There have been a number of issues for members in Spain such as slow fps within the game which suggest connection issues. Can you be more specific about the issues you're having? Is it an inability to purchase funds or to use them in-game?
    I am not an employee of EA/Envision. The views expressed are my own!
  • If your Funds have not been updating after you signed out and back into the game via front page please contact EA customer support directly.
    Envision Entertainment Community Liaison
  • Animals-Defence
    84 posts Member
    edited December 2020
    Wel can't by any funds for not one of my acc's doh. Also get alot of login errors , will post screenshot later

    ok update , lol now i can buy funds again , strange things lol
  • redirected to a dead end when trying to purchase funds
  • Can't buy funds at all anymore.. can not find a single working link to load the funds purchase page on any page.. everything redirecting to the stupid 'phenomic Tiberium Alliances' dummy page with half latin writing and no links.. good luck even finding tiberium alliances support in the main EA forums.
  • gamerdruid
    4063 posts Moderator
    If you go down the phenomic page you will see a drop-down that allows you to change the language - change it to American. This then allows the normal TA pages.
    I am not an employee of EA/Envision. The views expressed are my own!
  • Well, that changed the pages shown.. but now I get this page after sign in and clicking purchase ta funds goes to a blank page saying on 'purchase funds'.. here is a screenshot of the new post sign in page
  • gamerdruid
    4063 posts Moderator
    edited December 2020
    I've no idea if this will work for you - but give it a try:

    After changing the location to America, close your browser.

    Then reload the browser. Click on the little 'person' icon at the top right and 'sign in'

    On the startup page containing the errors, click on 'Purchase TA funds' - when I do this I get an offers page:

    I don't need to purchase funds yet so haven't gone further, but it 'should' work - but I don't know if it will!

    I am not an employee of EA/Envision. The views expressed are my own!
  • chadthurston
    136 posts Member
    edited January 16
    Post edited by chadthurston on
  • I already had 'united states' in the drop down.. it wouldnt work until I unchecked it.. also had to repeat it for each following page to show links.. seems like a mighty hokey way to do things.. never had this problem before.
  • Yes Chad ... this is true, but its a principle really. EA are dishonorable. My hard earned dollars will go elsewhere.
  • hi.

    Its working fine to buy founds under US...
  • gamerdruid
    4063 posts Moderator
    edited December 2020
    Your location needs to match the location of your IP address to be able to purchase funds. Unfortunately, at present, for some locations you need to have location set to the US to land on the correct landing pages.
    I am not an employee of EA/Envision. The views expressed are my own!
  • i can nit buy funds, need to fix bugs in the server
  • redmatch1
    69 posts Member
    edited January 4
    Because of your login page errors i cant buy funds on any account.
    get your act together!
  • same problem but game is dead so dont expect much
  • funds just keep trying click it once twice three time try another package, when it accpets go back to pick wheat you want,, as for log in page is wrecked but if u log in, then up in the right click play game you go to last server u played, or if u click home not play the world should pop up or change world will, but yes is messed up pretty bad, plus the zt trick is rife on vet, when i use the venom one on 39 had people moan i told them how to build to have game changed half way thought server, so now i have zt doing that, and rifle or missile men not shoot when they land in the base for nod, all this just to make issue for the real king. huhu uli uli uli
  • gamerdruid
    4063 posts Moderator
    edited January 4
    I've experienced the same thing - sometimes you can get through to the page, others you get a message referring you to ea.com/help which, when I tried it, was of no help!

    And before some know it all mod ;-} suggests it, yes, I tried different browsers, yes, I cleared cache, cookies and session files and yes, I flushed dns!
    I am not an employee of EA/Envision. The views expressed are my own!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!