EA Forums - Banner

Weekend AGAIN LOG ON PROBLEMS

In Red Banner
We>re sorry.but were having some technical difficulties. Try again later
also get when I try again
Your credentials are incorrect or have expired. Please try again or reset your Password

So What is it TECH PROBLEMS. CREDS EXPIRED. or PASSWORD

So far 5 hours not able to log on with my other accounts

This seems to happen EVERY WEEKEND . come on Devs. Tell the EA Devs to get there act together and let get this log in problem solved as its been going on for some months now

Replies

  • gamerdruid
    4043 posts Moderator
    The problem isn't general or there would be multiple posts about it.

    I would advise you to try direct world login - once you're on one world then you should be able to access others.
    I am not an employee of EA/Envision. The views expressed are my own!
  • nefrontheone
    795 posts Member
    edited May 9
    Could it be a problem located in a specific area/country?

    From Spain I am accessing normally, some worlds a little slow but in a normal way.
    Not a part of EA / Envision teams - My comments are only mine.
  • gamerdruid
    4043 posts Moderator
    If it is a country/region specific problem then EA/Envision can't help much.
    I am not an employee of EA/Envision. The views expressed are my own!
  • Errors like the one shown below continue to occur:
    g4lyx284pfwb.png
    But if you click the "Play now" button, you enter the game and you can play normally.
    Not a part of EA / Envision teams - My comments are only mine.
  • gamerdruid
    4043 posts Moderator
    The regionalisation by EA is messed up - I've got to be set to US English to get it to work. Maybe you could try setting your region in EA to US and then try. Not ideal, I agree. The language in the game isn't affected so you can still have the language set to Spanish if you wish.

    https://prnt.sc/12q96oz is at the very bottom of the first landing page. I also use https://www.ea.com/games/command-and-conquer/command-and-conquer-tiberium-alliances without any regional/country specific data and it works for me.
    I am not an employee of EA/Envision. The views expressed are my own!
  • EE_Elephterion
    1722 posts Envision Developer
    If you change the region/language setting on the landing page to one of the locales that EA is supporting, make sure to update bookmarks of the landing page. Previously supported locales that have been discontinued and that are still referenced by older URL/bookmarks may lead to the encountered errors.
    Envision Entertainment Community Liaison
  • nefrontheone
    795 posts Member
    edited May 10
    Where there are still a lot of problems is on EA's authentication servers:
    u4a9dqtynsv9.png

    Edited:
    I tried changing in the url "es-es" to "en-en" and load page, the game then loaded normally.
    Not a part of EA / Envision teams - My comments are only mine.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!