EA Forums - Banner

Problem to access this morning 14/1/22

1 posts New member
edited January 2022
Dear all,
I cant access to the game this morning. Somebody knows if there is maintenance running or some issues?
Thank you!
Post edited by gamerdruid on


  • Hi all,
    Can't seem to get in today, getting a big bright red screen and now can't get any further from the main screen at all?
  • xxsly
    92 posts Member
    edited January 2022
    I'm having issues as well. Was working fine around 4 hours ago and now I'm getting the too many redirects error. Clearing cookies didn't work either.

    Using Chrome Version 97.0.4692.71
  • Same here. Can't connect to any worlds. I am using Opera. One screen managed to show an error, myaccount.ea.com refused to connect.
  • game portal as provided on another thread no longer works, strangely enough it only failed after an update was installed, is there another link?
  • Hello Commander, are you using Firefox as your browser?
    Envision Entertainment Community Liaison
  • 82Paul
    1 posts New member
    Yep, same here in chrome. Familiar "too many redirects clear your cookies"
  • Hello Commander,
    what update exactly? There has been no update to the game recently.
    Envision Entertainment Community Liaison
  • I've merged the separate threads for a better overview.

    We think we have located the issue and hope to remedy this soon.
    Envision Entertainment Community Liaison
  • KerryHutton68
    54 posts Member
    edited January 2022
    I have deleted the cookies on both firefox and chrome, redirects too many times
  • chrome update
  • MD7707
    28 posts Member
    edited January 2022

    Same issue here. Tried Chrome (Version 97.0.4692.71 (Official Build) (64-bit)) and Firefox (96.0 (64-bit)).

    Tried another computer, same problem:
    I keep getting asked to login to ea.com, goes into the screen where I can click "Play now" and it returns to the same screen afterwards. When I click "Change world" I'm getting a smaller frame where the previous page with "Play now" is displayed. Even if I click there "Play now" it reloads the same page in the frame.

    Tried cleaning the cache on both computers.

    Any hints?
  • Quick update at 9:52AM (CET): Without doing anything it started to work. I've just opened a new tab and tried again. Works with both Chrome and Firefox (both computers).
  • ulthraxx
    1 posts New member
    Also cannot login this morning via worldbrowser or main page. Too many redirects respose. Tried Chrome which usually works and also Edge
  • The problem should be resolved as of now. A simple refresh of the landing page should be enough.
    If not, try to log out and back into the website should properly let you access worlds again.
    Envision Entertainment Community Liaison
  • Working for me now. Thanks EE
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.