EA Forums - Banner

Cannot get to the Homepage - Too many redirects?

Good day all.
For a while now I've been unable to get to the C&C TA homepage. I'm trying to select a different world but can't.
If I click play I get into my current world but if I click Home I get the error.
The error being.
This page isn’t working
www.ea.com redirected you too many times.
Try clearing your cookies.
I've tried the following so far...
Cleared the browser completely and disabled any and all extensions or plugins.
Tried both Chrome and Edge
Tried 3 different PC's
Tried launching from Origin, deleting Origin and trying again
Disabled all but necessary programs on startup and rebooted again with clean restart

Does anyone have a clue what is going on or how I can fix this please?
I was hoping to start the new server on the 28th but at the moment I can't.

Thank for any help in advance! Appreciate it.

ps. I've tried chatting to support 3 times and they have no idea so they sent me here ;-)


Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.