EA Forums - Banner

Madden NFL 20 - August Title update

Check out the first title update and share your feedback here

Anyone else unable to launch the game on PC?

Already been through multiple chats with tech support, followed all their recommendations. This is ridiculous, I don't even get an error message telling me what's wrong.

Replies

  • Update with more details, here's what I have tried after going through tech support:

    System specs:
    • Windows 8.1 Professional
    • i7 4790
    • GTX 960
    • 16 GB DDR3
    • Origin installed on SSD in C:/, Game installed on HDD in D:/
    • Clear Origin Cache
    • Run CC cleaner
    • Disable firewall/AV
    • Flush DNS Cache
    • Reset Host file
    • Reset IE settings
    • "Repair" the game
    • Reinstall the game
    • Run game/origin as admin
    • Clean booted PC
    • Clear Browser cache
    • Created a fresh admin account
    • deleted dbdata.dll, repaired the game again to replace it (Tech support id'd that library as an issue)
    • updated NVidia drivers

    still, cannot launch the game. I can see the executable start its process in task manager, and Origin updates to note I'm playing the game, but after a few seconds the executable exits immediately without an error message.
  • I also am unable to launch the game. My system's behavior seems just like yours:

    1. Start game in Origin
    2. Wait while it loads to a black screen (game's opening and you can see in Task Manager)
    3. Snaps back to Desktop, back to Origin client. No error message

    @Hilgyman I saw you in 2 other threads. Was your issue resolved? Some users mentioned a patch/update resolve their issue.
  • I am unable to launch from my desktop computer. I see the initial opening page graphic but nothing happens. Sometimes I just get a black screen. My system meets required specs. I have updated nVIDIA gtx 1060 driver and run DxSetup from Madden 19 folder. Reinstalled Origin. Deleted NVidia 3D Vision and GeForce Experience.

    My gaming laptop won't launch Madden 19 either. I get a DirectX error and nothing else. I've tried most of the same things listed previously.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!