EA Forums - Banner

Update requires ios 4.3! Older iPod users screwed?

This is stupid. I'm playing on a 2nd gen iPod too. Been playing this game for about 2 months on it, now suddenly I need to have a newer iPod/iPhone to update it? what the frig?

Replies

  • rachelmoody7
    20 posts Member
    edited October 2012
    Second gen iPods only have 128 MB of ram, compared to 1 GB with an iPhone 5. The game is pretty graphic intensive, especially as you progress. So yeah, you'll probably have to update to a newer device because the tech is out of date.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.