EA Forums - Banner
CLOSURE ANNOUNCEMENT: The TSTO forums will be closed on December 13th, 2023. Read more about the future of the forums here.

Cant connect to the server


  • Can’t connect to servers since 1/12/2018. iPhone X on 11.2.2. Game is on most current version.
  • My Mom is having the same issue but I am not (both Androids). We contacted EA yesterday when it started and they were able to fix it but this morning it happened to her again and now waiting on EA again.


    Someone posted this in general discussion in the same kind of thread there.
  • My iPad Pro couldn't connect on the 12th, switched to my old iPad and it worked till this morning...now all devices ( iPhone 6s also) getting the Bart reconnect screen over and over. IPad Pro was updated to new iOS, others were not.
  • Me, too. The problem is only on my iPad Air 2, running iOS 11.1.2. Worked great yesterday. Not so much today. Worried about completing Prepper event.
  • It has been two days for me. Southwestern USA Android user. Have tried literally everything imaginable. Uninstalled and reinstalled, was connected to server shortly, but booted very quickly after. Cannot get back in since.. any resolution in sight?
  • Me too. Pixel XL, Android 8.1.0
  • I had this issue with iPad and iPhone 7 yesterday. Was able to access last night but then lost server again and it’s still unable to connect.
  • anjavan
    4 posts Member
    edited January 2018
    I also cannot connect since 3 days. I deleted the game. Disconnected and reconnected my internet. Re-installed and reloaded the game. Was able to get back in for exactly 1 minute but then i got kicked out again. When will this be fixed?
  • Cannot connect to server. Same problem on both Android devices.
  • Everyone, try reloading game now. Couldn’t do it before? Took it of iPad and loaded it on phine. Let me play. Then logged out on phone and restarted on iPad. It’s working so far
  • I've discovered my issue in connecting is related to when the game tries to sync.
    shadoof07 wrote: »
    I have lenovo tablet android and haven't been able to log in for about 24 hours

    The problem persisted until this morning so I finally uninstalled and reinstalled then I could connect but my game hadn't save from the last time I logged in. When I was done tapping, I purposefully went to friends screen to get it to sync and then got booted when it tried to sync and after that I can't connect again.

    So my issue is related to when the game tries to sync. Maryland. Android. Lenovo.
  • Me too. Samsung S7 edge. Since yesterday evening.
  • I haven't been able to get into the game since the 12th. I'm playing on a pixel2
  • me too, using latest iOS. i am using iPad Mini 2
  • Have to same issue, have uninstalled and reinstalled fully twice and still wont connect to servers. Been out for about 24 hours now...
  • Same for me I have an iPad can’t connect to server. Lastest version.
  • since my last post ive had no connection problems. i urge everyone to try reinstalling again. i hope this helps even one of my fellow addicts.
  • I’m having the same issue on iPhone 7.
  • I’m having the same problems on iPad Pro. Tried un-installing and re-installing several times. Only worked once then same connection errors. Been going on for 3 days now.
  • since my last post ive had no connection problems. i urge everyone to try reinstalling again. i hope this helps even one of my fellow addicts.

    It helped me! But now I'm too scared to click into Krustyland or visit friends incase I get the Bart screen of death again D:
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.