EA Forums - Banner

Wish this lag would go away!

I just broke the tracks on all 3 new Itchyland rides and it still lags whenever I Recycle Metal. So annoying. Is there any other way to cure this?

Or is EA just giving us the big middle tapping digit?

Replies

  • Castiel19x
    3693 posts Member
    Have you tried nuking?
    Nuking is always the answer
  • Castiel19x wrote: »
    Have you tried nuking?

    Solid advice! You can never go wrong when you nuke! Look at how well it fixed Krustyland!
    I do not accept unsolicited friend requests! PM me and say hi first.
  • simpsonare
    2102 posts Member
    edited July 2018
    I just broke the tracks on all 3 new Itchyland rides and it still lags whenever I Recycle Metal. So annoying. Is there any other way to cure this?

    Or is EA just giving us the big middle tapping digit?

    Disconnect your newly created amusement rides.

    Oh, nevermind. You did it already.
  • KrustyBrand
    15340 posts Member
    I just broke the tracks on all 3 new Itchyland rides and it still lags whenever I Recycle Metal. So annoying. Is there any other way to cure this?

    Probably not the answer you want hear, but have you considered upgrading your device?
  • Hell no I ain’t nuking 5 years of work.

    And I have a newer phone with lots of space.

    This started same time as everyone else.
  • meinaz
    5440 posts Member
    I have never had any lag on my device. It may not account for all issues but I believe that the device people are using has a big impact on how the game works.
  • @audiomixdon .... store the 3 rides to see what happens.
  • my lag went away with the I&S takedown fortunately
    fast2shadow2 in Crawl to the Finish
  • KrustyBrand
    15340 posts Member
    Hell no I ain’t nuking 5 years of work.

    And I have a newer phone with lots of space.

    This started same time as everyone else.

    The nuking suggestion was a joke.

    You don’t say how “new” your phone is or how much free memory you have.

  • vibra5
    333 posts Member
    I solved by removing it from the memory cards to the phone's memory and deleting the data from the application settings
    when he is updated he is stable again!
  • audiomixdon
    296 posts Member
    edited July 2018
    I only have the lag when recycle metal is running. It’s a iPhone 6S+ with about 35 free GB. And it never lags or acts up other than Recycle Metal running.
  • Woo hoo! Easy fix.
    Some people just removed their entire Itchy and Scratchy Land and group storaged that dump. And the game is playable again!

    instantly those people were able to scroll like they haven't been able to do for weeks! Not only on the map, but scrolling through a character's jobs list is possible again! These people had forgotten what it felt like to swipe their finger and get results! One scroll now sends me (them) to the bottom of the menu, from 1 hour jobs to 24 hour jobs in 1 second! Massive rod! I swear Itchy is the devil.
  • simpsonare
    2102 posts Member
    edited July 2018
    Your phone. Not them. Someone hand me the megaphone please lol
  • Willy9292
    1317 posts Member
    simpsonare wrote: »
    Your phone. Not them. Someone hand me the megaphone please lol
    I have to, again, say there is merit in what @simpsonare says.

    I have family members using the following phones: Galaxy s7 x 2 Galaxy S5 Samsung A5

    The only devices that can use the rides are the S7s. The others lag too much to use. For these devices, the A5 being new, its not the game that is the issue. Turn off the animations and the A5 works fine, the S5 not so well even with them off.
    Unsolicited friends requests are all denied.Please PM me.
  • Grumpstown
    1362 posts Member
    edited July 2018
    Willy9292 wrote: »
    Turn off the animations and the A5 works fine, the S5 not so well even with them off.

    ive got the s5 as well, and it doesnt lag a bit with a clustered town and the rides all disconnected
  • simpsonare
    2102 posts Member
    edited July 2018
    Grumpstown wrote: »
    Willy9292 wrote: »
    Turn off the animations and the A5 works fine, the S5 not so well even with them off.

    ive got the s5 as well, and it doesnt lag a bit with a clustered town and the rides all disconnected

    Its within the phone. Nothing to do with programming other than it being heavy on the processor/memory. Try starting a new town and you will see how smooth your finger rides the screen. Putting items in inventory will solve this if you are not in the market for a new phone.
  • I am getting the very same issue when I do the recycle metal. It has been a problem since before the I&S land update.

    I am using a decent phone OnePlus 5 and it never lags for anything unless I recycle metal.
  • Store all the new rides in your inventory.
  • As for visiting friends. As long as they still have their rides hooked up and running, you can barely move the screens when visiting, or at all. As soon as the event was over, all the new rides went into storage.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!