EA Forums - Banner

The Simpsons: Tapped Out Bugs and Issues Thread


  • @11EEvey Thanks for the clarification. I couldn’t remember what to call the prospectors shack. I “collected” one deed from the shack at the same time as what I thought were deeds from Jackpot Realty, but like I said none showed up as deeds ready to use.
    This Northeast Passage is very confusing. This morning that one deed did show up and I was able to collect another one too for 2 expansions.
  • Hi all! I have suffered a big problem: after finishing the penultimate mission in this new event of the new land (the mission where you receive the buffalos and the little kind-of settlement) I closed the app but today when I opened it, all mi buildings and roads are moved and it seems like all bad configured: I have streets and grey floor in the beaches, trees in the streets, all my buildings and decorations sort of moved or get moved and some characters are frozen. I have contacted EA help and they told me this is beyond any bug fixing and the solution was to rearrange all my city manually. But they dont understand that there is floor in the sea and buildings that I cannot move, they are like stocked. Any recommendation?
  • @fermontesoca
    Contact them again and get a rollback to before this happened ASAP. Be polite but insist that they do this rollback as soon as possible as you will lose items gained since the last save they have on the server.
    Some have had this happen and have been able to fix themselves but it does not sound like you are able to. see this recent thread https://forums.ea.com/en/the-simpsons-tapped-out/discussion/274538/you-have-to-see-this-my-game-is-completely-ruined/p1
  • @11EEvey
    It seems they cannot do anything. I have contacted them and their response was:

    "From what I have found it is not possible to go back to a previous version of the game, i.e. before the changes. At the moment I don't have any further steps to recommend regarding the described problem other than the technical ones you have already followed. If more people report the same bug it will also be investigated by our technical department and they will post the news on the official EA game page"

    So, I just have to wait to see if they do anything, or I have to play with half of my city with no use or inaccesible. It's a shame!
  • that's **** contact them again
  • Anyone else missing their buffalo bridge? Did the quest but the bridge is missing. Uninstalled and reinstall, even tried on a different device but still no bridge or prospector shack.
  • 11EEvey
    2845 posts Member
    @faermaiden3 If you do not have the prospector shack the buffalo the trees and the veins on the new frontier land, contact EA ASAP for help. Make sure to choose technical support.
    They may try to tell you to post on the forums for help, just tell them you did and your game is broken and you need them to upgrade your support. Be firm but polite . You may have to call open more than one ticket.
    Contact EA through the game, the site https://help.ea.com/en/contact-us/?product=the-simpsons-tapped-out
    or on Twitter https://twitter.com/EAHelp/
    Chat or phone is best during business hours in US Central Time M-F
  • I have not been able to play game since they put the new log in. I lost last event. I still can’t do Christmas 2021. I’ve been playing since 2011 and never had problems like this. I’m only missing one Character in game . Please fix as soon as possible.
  • I've been locked out of Tapped Out for three days now. I've tried reinstalling, and force stopping, but I am still only getting the loading screen.
  • tarosim
    4 posts New member
    Hello everyone, I've been having this issue since the Christmas update and it is that every time I try to open the game I have to download all the updates again, sometimes more than 4 times in a day. I have uninstalled the game and downloaded it again but nothing. Does anyone know what I can do? Thanks :)
  • @tarosim
    This is usually a space issue. Clean off 6-8 gbs of space and reboot device. It may download again and then be good.
    If on IOS, make sure the offload apps feature is turned off, clear your cache, clear history on safari and spotify if you use them and you may need 10 gb free or 10% of your total storage free. IOS lies about how much free space you have so clear off everything you can.
    If you have more than 6 gigs of space clear your cache, uninstall, reboot, reinstall, do not play while downloading Only do this if you have an account
  • tarosim
    4 posts New member
    @11EEvey thank you so much for your help. I will do this and hope for the best :)
  • 1PPGax
    1 posts New member
    Bartscreen all the time, except the only time I play after reinstalling the game. I did uninstall and reinstall a few time theses days, but it happens to be very long and boring to do (and very data-consuming !). I tried to do it as well on BlueStack, with the very same result. (I also have more than 15Go avaible, so it doesn't have anything to do with this)
    Any advice on that ?
  • mjfox3145
    5 posts Member
    edited January 1
    I’ve suffered all the problems and faults that seemingly plague the other users of this game, but now I am stumped. I’ve had the ‘load further memory’ option and have been logged out. Now when I try and log back in, I enter the email address to get the verify code email, but nothing arrives. Yes, have checked spam. Yes, have tried multiple times. Still no luck. Now can’t play at all. Any thoughts?
  • 11EEvey
    2845 posts Member
    Go to ea.com and check your info, re-verify your account and change your password to have less than 16 characters with only letters and numbers in it.
    Try again if it still doesn't work Contact EA https://help.ea.com/en/contact-us/?product=the-simpsons-tapped-out
    or on Twitter https://twitter.com/EAHelp/
    Chat or phone is best during business hours in US Central Time M-F
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.