EA Forums - Banner

Money and land token issue [resolved]

9 posts Member
edited March 2019
Yo, after the latest update, 'State of Despair' the game is acting hella weird and no, I have not contacted EA because that ain't worth ****. Anyways, those buildings that got a 8/12/24-hr span of generating money is now generating money in minutes, sometimes even seconds.

And the land tokens, I have the Golden Goose Realty and I haven't gotten one token since this update and I need that ****.

EDIT: Got my first land token today. Last time I got one was like 5-6 days ago.

EDIT 2: Aight, it's reported to EA now. Hopefully they'll fix it soon.
Post edited by ambarinoix on


  • It is strange that this is still not fixed.
  • Having the same problem with the land tokens golden goose realty will refresh its time but not give out any land tokens
  • 11EEvey
    2639 posts Member
    edited March 2019
    You could try an uninstall reinstall (if you are NOT playing anonymously). Do not play until the game is fully downloaded, even though it says you can.
    Not sure if it would work, but EA would tell you to do that when you contact them, so better to go ahead and try.
    If it doesn't work, contact EA
  • bon0me
    16 posts Member
    I am having the same issue, I’ve contacted EA with my issue. Long story short I got an email that said they have updated my account with the missing land tokens however I have since longed in and there is no land tokens in my accoun, adding insult to injury no land token dropped on the recent tap of the Golden Goose.
  • @bon0me That's really weird.

    I did contact EA, though I reported it as a bug so I won't be contacted by them. Luckily, the land token issue has been resolved for me, I actually just got my second one today.

    You could try to uninstall and reinstall the app (if you have an account) and see if it works as it should and if you get those tokens as you should.
  • helnwhls331
    1 posts New member
    I am having the same issue with land token from the golden goose realty building and with donuts from the lard lad donut factory. Both just reset and do not give me donuts or land tokens. I have tried contacting ea help. It seems to be down. Contact thru both email and phone time out.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.