EA Forums - Banner

Can’t unlock any of my characters from Apu’s store

For the last week I haven’t been able to unlock any of my characters from Apu's store. When I tap on it to unlock the characters, they turn around and go right back into the store without me sending them there. There are three new missions that involve the Simpson family members and I can’t send them on their jobs because it has a glitch that won’t allow me to send them somewhere else. When I tap on the store, it doesn’t even show all the characters that are in there. I’ve tried to contact EA and have them correct the bug but it won’t allow me to send the report. Is anyone else having this problem? HELP


  • Willy9292
    1523 posts Member
    Pretty common issue dealt with in lots of threads, so the answer is simple. Just store the building and it will release everyone. Welcome to the forum, check out the tips thread.
    Unsolicited friends requests are all denied.Please PM me.
  • Either store the Kwik-E-Mart, or a building attached to one of the characters stuck. That should fix your issue.

    I would rather you do option 1 first over option 2.
    Trying to control the horizontal & the vertical. Do not adjust your TV.
  • Thank you so much. This really worked. I’ve been trying everything, I thought I was going to lose my whole game. I cannot thank the two of you enough for your advice. 😘
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!