EA Forums - Banner

Uh Oh! An unexpected error has occurred, please try again later....

Do you have the Halloween content? I also was playing on a 2nd gen iPod touch for a little while until the Halloween update. It told me I needed to update my firmware which u can't because in a 2nd gen iPod touch the highest is 4.3.1 or whatever .. Can't update it anymore and in the app store it says it only works for 3rd gen iPod touches and up now.. That might be the problem.. But if u got the Halloween then I guess I works
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.