EA Forums - Banner

Game crash

After the last update, I’m experiencing a serious issue: my game is constantly crashing as soon as I try to tap on Rabbi Krustofky or get close to the temple, where the Rabbi has completed his task and waiting. All the other characters are fine (I’ve currently about 450 characters in total). I was able to complete all the assigned tasks and send the characters again to new jobs, but no way to use Rabbi. I even tried to switch to a different device but without any difference. The game is correctly synced, but on both devices I got kicked out of the app as soon as I get close to the temple. Any idea or suggestion?


  • It was happening to me on my iPad. And I mean crashing to the home screen.
    For me it was Chalmers. Every time I hit him in the Character Finder I crashed. So I tried going to him from the Town Hall Town Census - crash. So I tried just finding him on the board - crash. Then it just started just crashing. So I uninstalled.
    Meanwhile I tried logging in from my Android Motorola phone - that worked. Note: the Android phone isn't updated yet. The update was only available to me on iPad and Amazon Fire.
    I was able to continue playing on my Motorola and completed my round of play. I've re-installed on my iPad - we'll see what happens. Meanwhile I've got an old Samsung tablet with touch screen issues. I'm going to update the game on that just in case.
  • It's crashing to the iOS desktop with regularity. I'm not sure yet what's triggering it, but it wasn't doing this prior to the latest game update. (I updated to iOS 14 yesterday and hadn't any problems with that alone.)
  • It appears to be a particular area of the game board, but it's random. When I try to move over to where Chalmers was I crash. On my iPad it's just to the east of the mountains where my Railyard stuff is.
  • Did they fix it? I logged back into my iPad with to report it with the in-game report system and it's not doing it any more.
  • It seems to be tied to one character, randomly. I had Dolph, others had Santa etc. Clicking their task icon to take you to them or even approaching the area they are in crashes the app. Mine was fixed by completely shutting down my device, others have uninstalled/ reinstalled.
    Give it a try.
  • The first thing I tried was a full shutdown. Then I tried a reinstall. It's working right now.
  • Last event it was running so smoothly as I was able to stay in designing my town, doing donut farming and now its back to crashing. :(
    Here have a banana!!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.