EA Forums - Banner

Apu’s apartment Christmas skin

How do you unlock apu’s apartment Christmas skin? I own it. It’s locked in my inventory. Also own apu’s apartment and have done the entire quest line and I’m maxed levels


  • Others have reported the same issue. You'll need to contact EA for help
    Contact EA through the game
    the site https://help.ea.com/en/contact-us/?product=the-simpsons-tapped-out
    or on Twitter https://twitter.com/EAHelp/
    Chat or phone is best during business hours in US Central Time M-F
    I believe they are closed for Christmas and will not return to regular hours until Sunday
  • I did contact EA. This was there response:
    nd I am happy to assist you regarding your issue.

    I can imagine that it can be frustrating and I am very sorry to hear that this Issue is causing you trouble, but rest assured, I will do my absolute best so that we can solve this together!
    I know this must be really frustrating, unfortunately, I was not able to find anything related to this as being acknowledge by our Team, so please report it as a bug on our forums.
    So I reported it. Any help would be appreciated
  • Was that by email. Email is the worst way to get help. Try to get chat or go to Twitter. Keep opening tickets until they help you. Other people have had this issue but no one has reported back if they got it fixed.
    Please go to EA answers and create a new topic about this
    include the type of device you play on please.
  • I have the same problem. I have apu's building and also crazy cat ladys house. In my storage I have both of their house Christmas "skins" but its locked and I can't use them. I contacted EA and they said its a bug and sent me this link to ask you guys what to do. And when I talked to EA, it was over the phone. Not email. So its up to you fine people. Can anyone help me with this bug? ... also, I logged on with my phone and also with my ipad to see if it didn't work on both devices. And it didn't. Still have the problem. Please help!
  • Sorry @dave1130, but you've been given the brush off I'm afraid.
    This is the players forum where we would be able to help you if it was something you didn't know how to do or were doing wrong, but if it's a bug in the game (as they themselves admitted to you) it's beyond our capability sadly.
    They should have directed you to the answers forum, which @1EllieG7294 has provided a link to in her post above yours.
    You clearly aren't the only person to have experienced this problem , so it's unlikely to be a device issue.
    Have a search around on the Answers site to see if someone else has created a thread and hit the "me too" button. Obviously 1 thread with multiple posts will get more attention from the developers than a bunch of 1 offs.
    Whether you find an existing thread or create a new one it would be helpful if you could drop back here and post a link to it, that way we can direct any fellow sufferers to add their voice to your cry for help.

    All the best of luck to you.

  • Thank you
  • Bumping this to see if there's ever been a fix for this before I file a ticket. I've tried the usual stuff but nothing worked.
  • 11EEvey
    3296 posts Member
    No fix for this issue and several others from last Christmas
  • Had a feeling but figured could hurt to check. Disappointing, I wanted to get all my lights up.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.