EA Forums - Banner

September 14th 2021 update issue

Ipad mini 2, OS 12.5.4, will download update, however when trying to play the game you can log in, but your town never appears and app terminates. Android not a problem - good to have a backup.


  • Same problem. Downloaded the update, it starts, it loads but the town never appears and the app terminates. I deleted the app, reinstalled it...same problem!
  • Same problem here, same device as OP
  • Having also this problem and same device.
  • Same here with iPad Air. I tried the various fixes and it still crashes at login. I tried their contact us form, but it wants a Mayhem id that you have to find in the build menu that I can’t get to.
  • The issue is logged here and on the Tapped Out site, so let's hope it gets to the Gods and it is sorted. Makes me wonder if it is an OS issue since not all apple devices affected.
  • Ipad Air. It's still not working. It worked before the update, then there was the update, and it doesn't work anymore. Why isn't it fixed by now?
  • lol you don't know ea very well and coding issues are harder than you think they are. Typically takes more than 26 hours to fix. A few dozen reports is not enough to marshal all their IT people to fix it.
    comment on the thread i linked and maybe they will start to realize there is a problem. Or maybe they planned it and aren't telling us anything. Who knows but EA
  • I have been having same issue for a few days now. EA support assures me they are “working on it”. I really hope so.
  • Unfortunately this issue will probably not be fixed until the next Event update (based on previous issues over the last 7 years of playing this game). Thankfully I also have an old Android device as a backup.
  • Guess what, there was an update and it still doesn't work! I will delete the game soon, since it doesn't work at all. Level 571, but I guess they don't bother to repair stuff,so after a couple of years playing the game, this will be the end, I guess
  • Ullwind
    1 posts New member
    I’m in the same boat with my iPad Air. It updated the new title screen & icon but still won’t open! I played everyday for years. I missed the convict event and now I’m apparently gonna miss the treehouse of horror event I’ve been looking forward to. So disappointed!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.