EA Forums - Banner

Multiple Quests not working

My friends and I can't even start the game litterally got all the way to Lisa's 24 hour homework quest which after that your able to build the school and the quest is no where to be found tried multiple things having all players off jobs, nuking the town, starting a new account everytime something messes up. That last update must of messed so much up please fix it! Me and my friends love this game (when its working) I'm too new to post URL's for my pictures I wanted to show so that's also bogus


  • 11EEvey
    3376 posts Member
    Quests require the right XP level but also require previous quests done. You probably have other quests that need completed first.

    Please read the following thread that gives advice based on the building


    You can also look the quest up on the Tapped out Fandom Wiki and use the preceded by link to see what you need to do

    If you still feel there is a problem after looking through the links, Contact EA directly for help

    The new member status is to keep spammers at bay. If you post the links I will repost them so they show if you still want us to see them @XhustleNdroX
  • This is my second account sir/ma'am so I know all the basic quests up to level 60 and also have read all the Tapped Out Wiki pages on quest order and characters needed ect. Litterally all the characters I own have that red Minus sign on them on there task book even when all of them are off there jobs. I did all the quests up until " The New Evergreen Terrace Part 5" then unlocking "We do need yes education part 1" which is Lisa's Job "Do next weeks homework (24 hours)" and which I click on lisa that job does not exist on her job list not even on the grey ones on the bottom that show there locked. So I litterally can not unlock the school or anything else after that. They legit need to fix this game. If I was able to post pics I would ill have to wait till my fourm account is old enough. Also if you look around like I jus did there are 100s of people who are also stuck since the last update. Soooo any options?
  • imgur.com/a/PIMD95K
  • Here are the pics I had to chop off the begging too make them post but if you copy and paste they will work. If you want any other specific pics please let me know
  • I'm literally so confident the game is broken that id give you the email and the 5 digit code that lasts for 10 minutes
  • 11EEvey
    3376 posts Member
    Those link do not work for me.
    Hundreds of people had a similar problem until the new update hit when they fixed this issue for them. Your issue though similar may be unique to you and a few others. I cannot tell there is a true problem until I go through all the normal stuff.
    No one here can help you if you think this is a legitimate issue, Contact EA for help.
  • just copy and paste them
  • 11EEvey
    3376 posts Member
    yeah i tried that Not stupid ya know. It was sending me to some random 404 page for a weird website. It is working today though, doesn't change the advice
  • The latest dinosaur update fixed everything with the quests so far! So looks like they found the fix! Good thing too I was about to give up on the game!
  • Cannot get the dinosaur game or the tv show game to work. Last daily challenge I did caused all my characters to be invisible and cannot do anything. Getting really tired of all these bugs every time there is an update for new content. Have had the tree quest stuck forever and can't finish that. Fix the bugs already!!!!
  • 11EEvey
    3376 posts Member
    @winnieinpink what level are you? Have you gotten the new update from the store? Have you done the initial tasks to start it? there are several you may have to scroll to see them all?
    You say you can't get it to work, what exactly does that mean?
    What does your characters are invisible mean? Can you give more information?
    You should contact EA about the tree issue and anytime stuff gets stuck. Don't let it sit and sit waiting for a fix.
  • Level 361. A few days ago I sent a bunch to buy milk at the kwik e mart for a daily task. I click to complete it but they seem to be stuck in a loop as they go right back in. Nothing seems to clear them from doing the task. I did get the latest update yesterday hoping it would clear it but it didnt.
  • 11EEvey
    3376 posts Member
    @winnieinpink Store the building they are stuck in, go to friend screen and back replace the building
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.