EA Forums - Banner

Town Locking up. Frying Dutchman 30 people finished

I just posted this before I saw you are having the same issue as I am

Just thought I'd put this issue here that my game is suffering from to see if maybe you all had tips before I ask EA for help.

I sent all my characters to the Fleet A Pita Van. They finished the quest, however after I clicked on the pile of thumbs up my game froze. Now every time I log into the game it freezes when my town comes up. I've tried the following with no success:

1. Exiting completely out of the game
2. Deleting the game from both my Ipad and Iphone and reloading it
3. Letting it sit for well over 10 minutes on the frozen screen

Does anyone have any advice with this before I attempt to contact EA?


  • tunseeker1
    32 posts
    edited November 2013
    Good luck, I have deleted it and reinstalled it and tried it on 4 different devices on iOS and Android.
  • general003969
    265 posts Member
    edited November 2013
    I have tried this as well, but it seems that this happens more then I thought
  • tunseeker1
    32 posts
    edited November 2013
    Fixed it!

    I kept logging in and going to other town and back to own town.
    It would sync coming back then lock up.
    I kept at it until the tasks finished and it let me in.
  • briangibson870
    71 posts
    edited December 2013
    Not just this particular situation store as much animated crap as u can leave it in storage and bring it out slowly balloons and flags whatever. U can also try logging origin on another device. U don't have much time u need to have storage button under thumb and move quick. U get a little more time with each try.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.