EA Forums - Banner

Anyone else experiencing building and landscaping glitches?

I haven't seen these glitches, but I often get some with my orange houses, fountains and camp fires that change to broken images of other buildings!

Replies

  • Starman_thc
    389 posts Member
    edited February 2014
    Yeah, I noticed one of those yesterday on my squidport. sort of looked like an Escher Painting...marge walking along next to the houseboat, then all of a sudden the top or her is gone and the houseboat is in front of her. A few minutes later another character walked there, and the same thing.

    Havent seen it since, but now that I know it is an issue, I will try to keep an eye on it...if my game lets me in tonight that is...
  • benjaminsamms
    102 posts
    edited February 2014
    Hey neighbor. I didn't notice anything funky in your town when I was leaving cards last night.
  • edited February 2014
    Made a post about this in Bugs & Issues, too. Has anyone tried uninstalling & reinstalling to see if it makes a difference? I am going to try soon, but if I can save time, I'd rather know ahead of time.
  • Undaunted-001
    2295 posts
    edited February 2014
    Iv had the crop glitch a lot :roll: When you harvest it. It does the growth animation rapidly. To stop it iv got to change the christmas lights back and forth lol. Looks awesome. Just wish I had somthing to record at the time :lol:
  • beeblebrox900
    1314 posts Member
    edited February 2014
    Big time.

    Seriously do they do any testing at all?
  • Starman_thc
    389 posts Member
    edited February 2014
    Made a post about this in Bugs & Issues, too. Has anyone tried uninstalling & reinstalling to see if it makes a difference? I am going to try soon, but if I can save time, I'd rather know ahead of time.

    Mine went away next time I logged in. Not sure if it is happening elsewhere in my town, but when I checked my Squidport last night, everything appeared to work as it should (except my ability to STAY in the game that is...).
  • marco_rosa833
    366 posts
    edited February 2014
    This glitch is severely afflicting my game. I can't even decorate anymore because of it.
  • bwsniper89
    6 posts Member
    edited February 2014
    Made a post about this in Bugs & Issues, too. Has anyone tried uninstalling & reinstalling to see if it makes a difference? I am going to try soon, but if I can save time, I'd rather know ahead of time.

    Yea i tried that. I asked ea and they told me to clear cache, uninstall/reinstall, log in/log out, yada yada. None of it worked, waiting for a response
  • mpwarner
    2971 posts
    edited February 2014
    Never seen those ones :-)
    .... But generally yes :roll:
  • Ecl3t1c
    63 posts Member
    edited February 2014
    Sorta glad to hear that I'm not the only one with this problem. I logged out and uninstalled/reinstalled the game too. I imagine that programming TSTO is difficult across platforms.
  • cornick1234
    189 posts Member
    edited February 2014
    I have texture/building glitches every time I play, trees/shrubs turning into characters, buildings turning into fragments of other buildings and moleman consistently disappears under the power plant. I just thought this was normal and have learnt to live with it, uninstall etc has no effect at all.
  • gidgetteandivory
    120 posts
    edited February 2014
    Me too. Mine seems to be limited to the purple house. It started after the Christmas update. Changing to the Christmas house and then back fixes it. Until it comes back.
  • Starman_thc
    389 posts Member
    edited February 2014
    I have texture/building glitches every time I play, trees/shrubs turning into characters, buildings turning into fragments of other buildings and moleman consistently disappears under the power plant. I just thought this was normal and have learnt to live with it, uninstall etc has no effect at all.

    I too have always had these texture issues, especially with the campfire, but this issue is very different.

    With the texture issue, if you scroll far enough away from whatever is messed up, when you scroll back, it is typically redrawn properly.

    This issue where items drawn on the screen are not properly situated with regard to other items around it is new. The pictures in the OP's post show it very clearly. This does NOT get fixed when you scroll away, and then back. Mine DID go away once I got out and came back in, but I don't know if this is the case with everyone else's, or if my issue has moved to a new spot in my town.
  • bren1960
    1631 posts
    edited February 2014
    Yes, when I move through my town buildings are missing til I get closer. I get broken pieces too. Doesn't really bother me. Use to it I guess
  • kevfd
    377 posts
    edited February 2014
    Ecl3t1c wrote:
    Here are some examples of the building and landscaping glitches.

    Screenshot_2014-02-06-13-33-362.jpg
    Screenshot_2014-02-06-13-34-362.jpg
    Screenshot_2014-02-06-13-34-112.jpg

    Same thing happened with the Xmas update also
  • edited February 2014
    bwsniper89 wrote:
    Made a post about this in Bugs & Issues, too. Has anyone tried uninstalling & reinstalling to see if it makes a difference? I am going to try soon, but if I can save time, I'd rather know ahead of time.

    Yea i tried that. I asked ea and they told me to clear cache, uninstall/reinstall, log in/log out, yada yada. None of it worked, waiting for a response


    Thanks for letting me know. I guess I'll put up with it for now until EA does something about it.
  • edited February 2014
    Made a post about this in Bugs & Issues, too. Has anyone tried uninstalling & reinstalling to see if it makes a difference? I am going to try soon, but if I can save time, I'd rather know ahead of time.

    Mine went away next time I logged in. Not sure if it is happening elsewhere in my town, but when I checked my Squidport last night, everything appeared to work as it should (except my ability to STAY in the game that is...).


    Glad to hear your cosmetic stuff is working as expected. Sorry to hear you're getting kicked so often. I usually take it as a sign that I need to stop messing around with my town and tend to my real life responsibilities... Then I log back in anyway.
  • keenyadaroddy
    3 posts
    edited February 2014
    When i go to lay down or pick up tiles, street or pavement the game freezes for about 2 minutes (which in game time is a lifetime) before it completes. Anyone experiencing this in their game? It actually started with the christmas update but when it ended the glitch ended. Now its back!!!
  • kitfisto2121
    92 posts Member
    edited February 2014
    Yep, my town is full of this crap.
  • zerudaa134
    58 posts
    edited February 2014
    I have this problem too. Like 80% of my buildings and decorations looks like this after the last update :( I can hardly see my Springfielders since it's basically just a pair of feet or if lucky a pair of legs out walking :( The town looks really messy now. And also There's a big glitch whenever I try to change water/road/pavement. The game freezes for about a minute before I can move on. I love the Valentine update but this glitching is just terrible :( I have also experienced the rapid grow glitch on Cletus farm. That was really something O_O
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!