EA Forums - Banner

last update killed the game finally for Android

Prev1
Yeah man im having the same problems here on my Galaxy Note 3.. the last 2 months have been horrible with KitKat, but now after today, wow... My Quad Core Device with 3GB of RAM feels like a Pentium 133MHz with 32mb of RAM.. Come on EA, what is the problem?

Are you trying to make all Android users quit playing?

Replies

  • NMayo
    898 posts
    edited May 2014
    I cannot set more then 1 character at a time before my phone goes to 0-1 Frames Per Second and then i cant set anymore ppl and then it crashes.. this is a freshie brand new uninstall/restart/install/update/restart/load.....

    unreal EA, please fix this and fix this quick, ive already been dealing with this KitKat crap for 2 months with absolutely 0 word from you on it even being an issue!
  • da_caveman
    169 posts Member
    edited May 2014
    Works galantly for me with ICS and JB devices.
    Maybe it's a kitkat issue rather than Android itself?
  • NMayo
    898 posts
    edited May 2014
    da_caveman wrote:
    Works galantly for me with ICS and JB devices.
    Maybe it's a kitkat issue rather than Android itself?

    it surely is a KitKat issue, but that is Android for sure, and everyday more and more devices get updated to KitKat.
  • Ambuler769133
    7 posts
    edited May 2014
    I have been having issues on my android galaxy s2 since the valentines update in feb. Some have just been resolved, but im still unable to play. All but 2 characters are stuck in tasks and most of my buildings say "waiting" on pay outs. Please fix. I used to love playing this game,bit now its just taking up alot of storage space.
  • annettemarc
    7734 posts Member
    edited May 2014
    da_caveman wrote:
    Works galantly for me with ICS and JB devices.
    Maybe it's a kitkat issue rather than Android itself?

    It was doing virtually the same thing on the iPad this morning. I have a Nexus7, and an iPad.

    It was awful on both the ipad and the Nexus after the update.

    I did the uninstall/reinstall on the Nexus, couldn't get in at all for a while and now can get back in but the lag is worse than before the uninstall/reinstall.

    I haven't done the uninstall/reinstall on the iPad ... It did no good on the android, made it worse, so why would I want that to happen to the iPad?

    I described it in another thread as being the same as watching the freeze-frame style intro "newsreel" type vintage style footage in the first minutes of "Butch cassidy and the Sundance Kid". (Assumes you're not too young to have seen it.)

    If my Springfield had Paul Newman and Robert Redford in it, I wouldn't mind the lag so much. :)

    USA/UK Race To Throw Country Into Utter Chaos = TOO CLOSE TO CALL
  • alealeale73
    96 posts Member
    edited May 2014
    NMayo wrote:
    da_caveman wrote:
    Works galantly for me with ICS and JB devices.
    Maybe it's a kitkat issue rather than Android itself?

    it surely is a KitKat issue, but that is Android for sure, and everyday more and more devices get updated to KitKat.
    It's not a KitKat issue.
    I have the same problem on my device which is an octa-core with 2Gb RAM running JB 4.2.2.
  • Snakeyees
    2321 posts Member
    edited May 2014
    I can not even get into the game it crashes both on my tablet and on my Samsung SIII
  • Pokelon1970
    311 posts Member
    edited May 2014
    Yes, correct, my Galaxy S4 doesn't have any chocolate either, so for sure.....game issue regardless of IOS.
  • da_caveman
    169 posts Member
    edited May 2014
    NMayo wrote:
    da_caveman wrote:
    Works galantly for me with ICS and JB devices.
    Maybe it's a kitkat issue rather than Android itself?

    it surely is a KitKat issue, but that is Android for sure, and everyday more and more devices get updated to KitKat.
    It's not a KitKat issue.
    I have the same problem on my device which is an octa-core with 2Gb RAM running JB 4.2.2.

    Damn odd.
    My JB(4.2.2) device only holds 768 mb ram, and its speed is 1,2 ghz.
    A Samsung GT-S7580.
    Tapped Out runs smoothly on my screen, no lag issues at all.
  • Tischoo
    61 posts
    edited May 2014
    Just wondering that EA not check their updates at all :x otherwise they would have noticed that there are big issues on the most common platforms. So do they spend the money from the donuts just in developing??? Even than they should check what they doing ( OK, i am working in this area and developers are never good testers :wink: )

    As this is an production blocker, i would expect a fix within 24hours as currently nobody will spend donuts, in fact they are not able to do....

    And also lagging is just in Springfield, once you enter Krustyland everything is running fine!

    Please EA get awake and hurry up to fix this... People maybe complaining in the forum to much about to many topics, but this here is really essential :evil:


    UPDATE

    After 5 crashes and some lags i was able to finish "chocolaty grief PART12" (translated from german..) and NOW the lags are gone. Game crashes still at start or after 2 minutes in the game, but at least i can tap in time?!

    MAybe this helps in finding a reason.. Has anyone else the same behavior??



    UPDATE 2

    Now 5 minutes later lagging is starting again for a few seconds, now it´s more or less a random issue at some point in time but not always...

    Maybe this is server related?
    Post edited by Unknown User on
  • NMayo
    898 posts
    edited May 2014
    NMayo wrote:
    da_caveman wrote:
    Works galantly for me with ICS and JB devices.
    Maybe it's a kitkat issue rather than Android itself?

    it surely is a KitKat issue, but that is Android for sure, and everyday more and more devices get updated to KitKat.
    It's not a KitKat issue.
    I have the same problem on my device which is an octa-core with 2Gb RAM running JB 4.2.2.

    yes it seems that this problem that we are all having is not JUST KitKat related, its Apple and Android and everything. the KitKat issues themselves on top of this are horrendous..
  • Dha12oks
    7 posts
    edited May 2014
    Glad to know I ain't the only one experiencing this problem...

    I thought it was compatibility issue with the new Samsung Galaxy S5 which I recently got, though on my old S3 it isn't lagging, then again I have started a new account on it, so less to load lol, still really annoying, wish they would fix this already..
  • englishcaper
    6 posts
    edited May 2014
    When i log into mine it gives me a brand new empty town, On the log in screen it says I'm at level 40 but when i tap to continue I get loaded into the animation that begins the game and then it starts me in a new game.
  • Ataccounting
    84 posts
    edited May 2014
    I'm another one. Samsung Galaxy S3 running Android 4.3


    Really bad lag. 20 minutes to clear buildings and characters and reset my town.
  • NMayo
    898 posts
    edited May 2014
    yup.. nothing has changed for me either on my Note 3.. 4.4.2 ofc...
  • matildawr
    49 posts
    edited May 2014
    Good thing I saw all these updates about how bad the update is because I have not yet updated my game, still have the easter event.
    Gonna go on and see if its laggy for me too, if it is, it is not the update but something else, amybe server related?
    ...
    Oay, went on and it is NOT laggy for me. It is just like it was with the easter event. So must have something to do with the latest update and cover all platforms..
  • NMayo
    898 posts
    edited May 2014
    matildawr wrote:
    Good thing I saw all these updates about how bad the update is because I have not yet updated my game, still have the easter event.
    Gonna go on and see if its laggy for me too, if it is, it is not the update but something else, amybe server related?
    ...
    Oay, went on and it is NOT laggy for me. It is just like it was with the easter event. So must have something to do with the latest update and cover all platforms..

    yeah it seems to be randomly affecting different devices. theres a 9 page thread on it here in the bugs/issues forum with a boatload of random devices.
  • Tischoo
    61 posts
    edited May 2014
    today´s update (once started game) made it not better, lagging is still there and for me more bad than before ( as it was better in the meantime)

    Also we have now an new FP level (thanks for this new Lisa skin, really nice :), hopefully we will get the chance to grab it ), however by tapping friends, no FP´s are given

    P.S: KrustyLand still runs smoothly without lags for me....
  • wesker_chi727
    10 posts
    edited May 2014
    Not just an Android issue, I'm having lag problems on both my iPad and iPhone, plus a friend of mine is having the same issues with her kindle. Sucks for ppl higher in levels even more cause we have more animations going on which is where the issue lays.
  • fuffazzoni
    627 posts
    edited May 2014
    You're lucky tou can say you lag. I can't, because I can't even log in, it always crashes before displaying the town.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!