EA Forums - Banner

Update on Ipad

Update on Ipad, still no access to my town :hunf: :thumbdown:

same here on iPhone, the update loaded, but still can't get into my level 40 town :cry:

Replies

  • ZIPPYUK
    6 posts
    edited May 2014
    **** EA sort your **** selves out, ok got update can get into my town, however unplayable lags like *.
    SORT ****
  • toeslove8
    10 posts
    edited May 2014
    Still no access for me either after update. Update still says 4.8.1 with level 40 description...
  • maximbarne126
    3911 posts Member
    edited May 2014
    Unlucky, you would think that they would fix the lag before releasing level updates! :/
  • Calabahn
    3 posts
    edited May 2014
    Got the update and TSTO still crashes back to the home screen. EA also closed the tickets I opened as resolved.

    This is not resolved. I've spent real dollars for donuts over the past two years. Come on EA get it together.

  • finagenesse
    514 posts
    edited May 2014
    I send an email requesting an update on my open case. It's my third time being locked out in a month. First two times they said it was a corrupted file and they fixed it by retrieving an older file of my game. I have a hard time believing that the problem is with the app and not with their saved data... Since people with different devices are affected and because it looks so random.
  • cavemanphoto
    10 posts
    edited May 2014
    Many in game crashes over past weeks or so. Worse 2 days ago when I could not get into friends, scratcher or sideshow you without crashing.

    Even tried deleting and full reload without success.

    Using 1st gen iPad mini with few bugs until after the very disappointing Easter event ended.

    Bad news is my in game purchases over past 1.5 years are lost. Good news is I can now get on with my life.

    :shock: :cry::cry::cry:
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.