EA Forums - Banner

Freezing when placing buildings etc

Mine did this when I had nice fancy bridges everywhere and the half birdge walkways along the water.. once i removed all of that, the lag when trying to move stuff went away.


  • annettemarc
    7747 posts Member
    edited May 2014
    Is anyone else having problems with the game freezing completely when you try and place buildings or items in certain places of your town? Most places it works fine but there's a number of areas where nothing can be placed anymore.

    I've been trying to do a small redesign due to new buildings and lack of space but can't complete it due to not being able to place a number of buildings where I want to. Even though there used to be buildings there and there is nothing in their way. The area below turns green like normal but when clicking on the tick to place it, the game freezes and never recovers.

    Anyone got any suggestions? I've stored a tonne of items in order to be well below the decoration limit but this hasn't helped at all. I've also uninstalled and reinstalled more times than I wish to remember.

    I've also opened a ticket with EA but not heard anything back after having my case "escalated to the specialist team".

    This EXACT thing happened to me.

    It's different than the whole-town problem of freezing. I had THAT until demolishing my bridges, etc, a month or so ago, and all was fine.

    But THIS is different. There's only one area I've noticed it in so far, but haven't been moving stuff around in other areas of town, so there may be more than this one area. All the surrounding areas work fine, but an area about the size of four plots of land totally freezes just from setting down one teensy item. Though if I wait long enough it unfreezes. (I just went and timed it at just under 2-and--a-half minutes.)

    If they fix yours, let me know. It happens to be an empty place in my Springfield, but has been developed in the past. Does yours happen to be empty at the moment?

    USA/UK Race To Throw Country Into Utter Chaos = TOO CLOSE TO CALL
  • Kozzi59
    1393 posts Member
    edited July 2014
    I've been having this issue since the Stonecutters event. I've got new land with a lot of houses dumped on it that I wanted to design, but whenever I try to move one house, the game freezes. I've refrained from trying to move anything for the past two weeks, hoping EA might have fixed the bug (HA!) and tried again this morning: first house I tried to move, the game froze.

    Think it might be time to abandon the game, or at least put it into cold storage (appropriate) until this issue gets sorted out. Can't see much point in continuing if I can't keep growing my town. Pity, because up until now it has been a lot of fun.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.