EA Forums - Banner

Emblem prize glitch?

I'm having the same problem.

Replies

  • Appleseed1175
    7 posts
    edited June 2014
    Ditto - I thought it might be because I unlocked burns yesterday on my iPad, but I'm playing today (at work -shhh...) on my phone.
  • eltaylor123
    2 posts
    edited June 2014
    Mine has done the same but on the first prize, any idea how I might be able to sort it?.
    Please
  • SLovely85
    2 posts
    edited June 2014
    I have been having the same issue on the first prize. It has prevented further prizes from being unlocked even though I have almost 7500 emblems. I don't know what to do about it!
  • CamieSpice
    47 posts
    edited June 2014
    I'm having the same problem with the Burns emblem.

    Please fix EA!
  • FeeFyeFoeFum
    245 posts
    edited June 2014
    Yup, count me in.

    Unlocked the money pool today, placed it in me SF, set mr burns of on his swimming task and logged out.

    When I logged back in later on, the reward screen popped up again telling me I had done well and the money pool was in my inventory, ready to place.

    I checked, it was still in me town, task half way done, no duplicate in me inventory.

    However the emblem reward screen has the money pool blacked out and it says I need -10 donuts to unlock it.

    Each time I log in or go to Krustyland, the reward screen pops up telling me I have unlocked the money pool, its in me inventory, etc.

    I have deleted data, cleared cache, uninstalled and thena fresh install, still no joy.

    I am wondering if this means I won't unlock any other prizes as the game thinks I haven't unlocked the money pool, despite it being there.
  • fiedlerj
    19 posts
    edited June 2014
    Add me as another person with this issue :\

    Well I was having this issue as of about an hour ago but I just logged back in and it seems to be resolved... for now at least LOL.
  • ssam87
    51 posts
    edited June 2014
    Same problem for me. Does anyone know the email address for customer service? Thanks.
  • fiedlerj
    19 posts
    edited June 2014
    Well.. while the problem seemed to be resolved for me for about an hour... this morning it is back >_<
  • FeeFyeFoeFum
    245 posts
    edited June 2014
    fiedlerj wrote:
    Well.. while the problem seemed to be resolved for me for about an hour... this morning it is back >_<

    Bugger matey, was hoping after seeing your post that it might sort itself out for all of us effected. Think its gonna take some work from EA on their end, as it's the info in their database/servers which is now glitched.

    Fingers crossed we still can get the prizes if we earn the emblems, otherwise its gonna be a boring/frustrating event
  • ck2875
    2 posts
    edited June 2014
    I'm having this exact issue with the Mr. Burns Robes / Money Pool reward. It's currently sitting at -5 donuts required to unlock it. Hopefully this gets resolved because I was really enjoying this event.
  • ssam87
    51 posts
    edited June 2014
    The problem seems to be fixed for me (was okay this morning when I checked after going to sleep).
    What I did was go visit some towns, tap their buildings and collect a few emblems then I went back into my town.
    The message that I just earned Burn's stone cutter outfit and pool of money disappeared and the reward wasn't blacked out anymore.

    Maybe give that a try?
  • ck2875
    2 posts
    edited June 2014
    ssam87 wrote:
    The problem seems to be fixed for me (was okay this morning when I checked after going to sleep).
    What I did was go visit some towns, tap their buildings and collect a few emblems then I went back into my town.
    The message that I just earned Burn's stone cutter outfit and pool of money disappeared and the reward wasn't blacked out anymore.

    Maybe give that a try?

    This also worked for me. Thanks!
  • Snapcptn
    2 posts
    edited June 2014
    ck2875 wrote:
    ssam87 wrote:
    The problem seems to be fixed for me (was okay this morning when I checked after going to sleep).
    What I did was go visit some towns, tap their buildings and collect a few emblems then I went back into my town.
    The message that I just earned Burn's stone cutter outfit and pool of money disappeared and the reward wasn't blacked out anymore.

    Maybe give that a try?

    This also worked for me. Thanks!

    Awesome! That worked!
  • last0417
    4 posts
    edited June 2014
    As me to the increasing numbers of plates with the same issue. Can't get additional stone cutters
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!