EA Forums - Banner
CLOSURE ANNOUNCEMENT: The TSTO forums will be closed on December 13th, 2023. Read more about the future of the forums here.

Level 43 Bug on Princess Quest



  • jamijamule
    3 posts
    edited July 2014
    Same here: the game don't recognize my balloons (i have 4 of them now and i built the first two before quest started) and still stuck on task 1 of this quest

    it's been a week and still no update... kinda frustrating
  • dkhang8
    27 posts
    edited July 2014
    I'd writed to the worst customer service EA for more than 4 days now,anh they did not give me an answer to my inquiry yet
    they do not care about us players, they are only care for our money and donuts. EA has the worst customer service I have ever seen. it's ok with me, I WAS your primium player in level 43. it's time to delete this ******* game with so many bugs and issues, and EA with the worst customer service in the world. it help to be quiet, right EA.
    I hope you going bankruptcy, EA. the worst company with the world worst customer service

    I had that problem with Princess Penolope task 1 (the princess and the pea-brain pt.1) place balloons 0/2, and build krysty giant wheel.
    I have built Krysty giant wheel, and I have 3 balloons of each itchy,poochie parade and scratchy, but I still can get the task completed, it still said 0/2 in place balloons..
    I just bought them, in krystyland (decorations) . 3 of scratchy balloons for 1250 each, 3 of poochie parade balloons 1000 each and 3 of itchy balloons for 30 donuts each. Now I got over 20 balloons
    I also store them and replace, but nothing help..
    I also stop the game and reinstall the game, but nothing help..
    that is annoying, I have tryed EVERYTHING...store Giant wheel and Princess Penolope in inventory, store balloons in inventory..and also buy new balloons again..but nothing help.
    I click KL task icon and buying them, and also buy them in decoration
    And I have raised a ticket with EA, just wait and see what will happen
    Post edited by Unknown User on
  • smohqy
    2113 posts Member
    edited July 2014
    Miggwilson wrote:
    Well...frankly this sucks. I have the problem and I've tried several things...

    *selling the balloons...won't let you.
    *put them into storage and tried pulling them out and placing them...still shows 0/2.
    *tried buying new balloons and placing them...still shows 0/2.

    I am now up to six balloons with no end in sight. I completed the ferris wheel...thought that would help...ah....NO.

    And I am not buying another dumb balloon. EA...Fix this.

    Exactly the same issue for me. Luckily I warned my wife to wait for the prompt before buying balloons.

    I'm low on tickets, so I guess I'm just gonna have to wait for a fix before continuing.

  • Miggwilson
    37 posts Member
    edited July 2014
    Has ANYONE gotten a good resolution from EA or if they filed a 'ticket' with EA...did they fix this for you?

    I am still waiting on an update to correct this.
  • jamijamule
    3 posts
    edited July 2014
    Nothing new?
  • smohqy
    2113 posts Member
    edited July 2014
    I think (at least on my end) it has been resolved, as I am now finally up to Princess and the Pea Brain - Part 2.

    I only spent an add'l 1,250 tickets on an extra balloon to realize it wasn't working. Hopefully those that dropped lots of tickets and donuts will be compensated for this error.

    But give EA credit. They're working with an ever-expanding world, with - I can't even IMAGINE how many players - to provide us with new content across many platforms.

    Also take into consideration that every shrub you move is making a change in their servers.




    So just consider that someone might have entered a '+C' instead of a '-C', or whatever code-monkeys do - I dunno, I'm kind of a technidiot. But I DO realize that such a large, ever-changing mega-user-verse such as this is bound to be fraught with imperfections.

    Hell, I used to be the mail-person for WFS and Broadcom through Xerox Business Services in Irvine, and the Post Office would frequently give me EA's mail by mistake. Even the USPS couldn't get it right. But I always sorted their mail out of ours and made sure it was delivered to EA that same day, or worst case, the next day.

    So, short story long: I've been frustrated with TSTO occasionally, but it usually works out in the end. Just accidentally getting their mail by accident was hard for me. Just imagine what they actually received back in '96 compared to what they receive now.

    My 1/50 of a dollar.

  • suropah
    6 posts Member
    edited August 2014
    No change here, still stuck on part 1. Hoping the next upgrade might help?? whenever that's due? ?
  • operations45
    1 posts
    edited August 2014
    I am also having this problem in part 1. I've tried all of the suggestions in this forum without success.
  • wdrwmn13
    1 posts
    edited August 2014
    The game won’t let me build Duff Pavilion. I’m level 43, it tells me reach level 29 & start the “the krusty-est place on earth pt38?quest any ideas?
  • maxeerg
    1010 posts Member
    edited August 2014
    wdrwmn13 wrote:
    The game won’t let me build Duff Pavilion. I’m level 43, it tells me reach level 29 & start the “the krusty-est place on earth pt38?quest any ideas?
    You must fulfill both requirements. Look at the items on your task list while in Krustyland. One of them will probably be the Krusty-est. It should tell you where you are currently. You will need to progress through every part until you get to part 38.
  • bennyquixote
    14 posts
    edited August 2014
    Has anyone heard anything on this yet? I've finished all my tasks and can't do anything until they fix this glitch.

    It actually told me the task was completed today after I bought an extra balloon. When I clicked to go to the task it went back to not being completed. :(
    Post edited by Unknown User on
  • charmstar871
    17 posts
    edited August 2014
    My problem is similar, yet different. I placed the balloons. and that's as far as I got. Then the quest just disappeared all together. I dont know what stage it was at, its just not showing at all now. no icon in the left. I never even got to build the ferris wheel. anyone else get this?
  • jlh512
    2 posts
    edited August 2014
    I contacted EA and spent an hour on the phone with them for them to tell me they are aware of the issue and they could not push me through it. They said it would be fixed with the next major update. Well I just downloaded the major update and it did not fix it! Come on EA. It's been over a month that we have been stuck! M
  • melona75
    9 posts Member
    edited November 2014
    I also can't build Duff pavillion,it's still locked. I'm level 44 and have completed all the quests leading up to The duff pavillion. Now what?
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.