EA Forums - Banner

Ice cream truck issue

jbelknap wrote:
I got the offer for the Gil deal. After considering, I want to buy the truck. The truck isn't in the buy menu and I can't tap on Gil. I've tried closing the game, logiging out, turning my iPad all the way off, visiting friends and Krustyland, logging in on my phone and no dice. Any suggestions? Is frustrating watching Gil walk around my town begging and not letting me tap on him.

uninstall and reinstall the game? Just guessing here, I really do not know but that seems to fix major glitches like that.

Replies

  • Neglecterino
    5175 posts Member
    edited July 2015
    For me it is on the front page of the shop. Also in the New! page, and the Premium page. Maybe try those other pages? If that doesn't work I suppose an uninstall/reinstall would be the next try.

  • jbelknap
    57 posts Member
    edited July 2015
    It's not on the new page or the premium page. and I tried uninstalling and reinstalling on my phone. Still no luck. :( I guess I can try uninstalling and reinstalling on my iPad when I get home.
  • johncolombo
    11247 posts Senior Moderator
    edited July 2015
    found this from an issue another player had in the past with a gil deal

    "I didn't get it immediately after upgrading either. I had a random task I had to clear first before Gil's dialogue started"

    do you have characters on random tasks? Maybe trying storing some characters from your task list then put them back? Worth a try.
    Volunteer EA Forum Senior Moderator/Hero EA Answers HQ
  • jbelknap
    57 posts Member
    edited August 2015
    I reinstalled on my phone and iPad and still no joy. Gil wanders around my town and won't let me tap on him. I'm in the process of trying to clear a couple of tasks to see if that helps.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!