EA Forums - Banner

Monorail causing buildings to disappear

I had a similar problem. I was having problems placing one of the new s-shaped track segments when the screen blanked and came back with nearly 1/4 of my town gone, including HALF THE MOUNTAIN RANGE!!

Restarting the game shows the missing buildings as it is prompting you to buy them again. Once you start doing anything, they disappear again, taking the mountain range with them. Along with the missing buildings I am missing all the characters associated with the buildings.


BIG BUG!!

UPDATE:

The following procedure recovered all my buildings and characters: (I know this has been covered elsewhere but hopefully this will be easier to follow)

1. REMOVE MONORAIL TRACK starting with the most recent pieces you placed. When you remove the offending piece, your buildings will reappear. (Restarting also makes them reappear but they soon vanish when you start playing)

2. Insure the buildings are really back for good by playing a while, move a formerly vanished building, etc.

3. All your disappeared characters will probably still be gone at this point.

4. Check your inventory for buildings with characters to find out which ones are affected. DO NOT TRY TO PLACE THEM FROM THE INVENTORY. This will not work and cause problems later.

5. After making a list of the missing characters, go to to each character's building and store it and THEN re-place it from your inventory. If your character appears on screen, you have done it right.

6. Repeat with other buildings and characters being careful to store the building before placing it from your inventory.

7. If you did not follow step 4 and built building from the inventory without storing them first you will have to wait for them to complete building, then store them again. (This can result in duplicate 'unique' buildings. I have two retirement homes, one Abe, and so far no problem but who knows what problems may lurk for the future? My extra retirement home is in the middle of the mountain range, since my mountain range disappeared during the glitch and I just dumped the building in a blank part of the screen before I figured out this fix.)

8. DON'T PLACE ANY MORE MONORAIL TRACK until EA fixes this thing!! My system is back to normal and working okay but I am sure if I place one more piece of track the problem will probably hit again.

Replies

  • Snakeyees
    2319 posts Member
    edited August 2015
    Contact EA through https://help.ea.com or try a reinstall maybe
  • Ftball2theGroin
    594 posts Member
    edited August 2015
    There are a bunch of threads in the Bugs forum about this problem. It happened to me and lots of others. Basically, you need to store all the affected buildings and re-put them in your Springfield. The only problem is if it had affected a non-storable building, like the Simpson house or the Project Board.

    Personally, I had to have a rollback to before the bug, but many others have been able to fix it by storing everything. Anyway, I have to admit that EA was very helpful and fixed everything eventually.
  • AARONRTD
    1807 posts Member
    edited August 2015
    Well I fell hard into this glitch pit now I cant use 7 people to get stuff, not a big deal but very annoying.
  • Mopurglar
    1048 posts Member
    edited August 2015
    I haven't updated yet and am hesitant to do it now because of this thread.

    How can I avoid this happening to me?

    If I put all of my tracks in one empty corner far away from any buildings, do you think that would help? I prefer to leave my tracks out in order to generate possums.
  • TwigletStyx
    1039 posts Member
    edited August 2015
    Mopurglar wrote:
    I haven't updated yet and am hesitant to do it now because of this thread.

    How can I avoid this happening to me?

    If I put all of my tracks in one empty corner far away from any buildings, do you think that would help? I prefer to leave my tracks out in order to generate possums.


    This. ^

    I knew about the update early on, but decided to watch threads before making a decision...
    This is our last dance. This is ourselves under pressure.
  • starstrucsims
    343 posts Member
    edited August 2015
    I had stored some tracks and moved others. Today I tried to bring the tracks back to the terminal. I moved all important buildings out of the way so they are not near the tracks anymore. Then I replaced the tracks. So far, no problems. I think if the tracks are not near anything, you shouldn't have a problem.
    I didn't realize until after I posted this that I had lost my Lunchlady Dora. She had just disappeared when the buildings disappeared. I stored her building and when I brought it back out, there she was.
  • Mopurglar
    1048 posts Member
    edited August 2015
    looks like the update is required now. these guys are ridiculous.
  • Neglecterino
    5175 posts Member
    edited August 2015
    Thanks for the heads up everyone. I'll be keeping my track in inventory despite only getting 8 possums until this is fixed. I had them in inventory anyway because of freezing issues. At least at the moment I'm a day ahead on the calendar to get the final prize for act 2.
  • Ftball2theGroin
    594 posts Member
    edited August 2015
    I don't think it has anything to do with the update, as a lot of these glitches (including mine) were reported before it hit. It's definitely related to the monorail tracks, possibly something about connecting/disconnecting them to/from a station, which triggers the train animation. My glitch hit when I was moving the tracks which connected to the Tetanus Station.
  • Cobrando23
    15 posts
    edited August 2015
    This is STILL happening. I attempt to move or store items and almost everything around the area disappears- and they don't get put away into inventory. When I exit the game and come back everything is back, but when I tap the project board it takes me to the buy menu to buy a new project board. Buildings and decorations continue to disappear and I don't know what to do about it- cannot complete projects so I'm no longer earning tracks :( I'm beyond disappointed. Especially after I just dropped a bunch of money on premium stuff.

    EA, if you read these boards, PLEASE do something about this huge glitch. Does anyone know if they are aware??
  • shawn59736
    540 posts Member
    edited August 2015
    I had this problem 2weeks ago and this is what I had to do: 1. disconnect your track pieces- my glitch seemed to be directly connected with a certain piece ( or maybe the placement of said piece). 2. Store, then replace all the buildings that disappear, you will get your characters back and start making money again on these buildings. 3. Contact EA.
    It took over a week with a "specialist " working on it but now everything is working fine. I did reconfigure my monorail track just in case it was the placement of the track piece. They also rewarded me with a fine bunch of donuts for my inconvenience.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!