EA Forums - Banner
CLOSURE ANNOUNCEMENT: The TSTO forums will be closed on December 13th, 2023. Read more about the future of the forums here.

Will not allow me to complete Narcoleps-Zzzzzzz Pt. 3 'Place Oedipus Rx'

I have the same issue...I couldn't figure out a solution either.


  • enque_obscura
    8 posts
    edited September 2015
    Anyone else having this issue? None of the updated stuff shows up past the 'Place Oedipus Rx'.
  • Brandofied
    9 posts
    edited September 2015
    I had the same problem, I think. On Wednesday I updated my game for the episode tie-in and worked through the storyline. I got to Part 3, started building Oedipus Rx and sent Homer to take a nap. The next day my game updated with the Unemployment Office/IRS updates and when it did my Oedipus Rx building went missing. It wasn't in my inventory or in the build menu either.

    So last night I contacted EA via the Live Chat support option and explained it to the Game Advisor. Not sure what he did on his end, but he eventually had me log out and when I logged back in he building was waiting for me in my inventory. I'd recommend contacting EA to get this resolved. The wait was about 45 minutes last night, but they were able to fix it for me within about 15-20 minutes.

    Hope that helps!
  • enque_obscura
    8 posts
    edited September 2015
    Problem solved. I too did a live help chat with EA and they fixed it to where I got the Oedipus Rx building. I still do not have the Statue of Burns for sale in my store but I'm not looking to pay 50 donuts for that anyways.

    Anybody with this issue I recommend doing a live help chat with EA too.

    It took me two tries. The first time the administrator tried to place the item in my inventory but I did not see it. He said there were too many items in my inventory and I needed to make room (been renovating my Springfield which why I placed all my items away) but it should appear after I make room. Did not work. Second time, with inventory purged, was successful. It took about over an hour total from start to finish but got my building.

    More people reporting this problem the more likely it will be resolved. Thats my only answer.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.