EA Forums - Banner
CLOSURE ANNOUNCEMENT: The TSTO forums will be closed on December 13th, 2023. Read more about the future of the forums here.

My town's layering is way off!!

There have been quite a few posts about this issue recently, it seems that and old glitch has come back to haunt some people again, unfortunately I've seen no fixes posted so far I know that last time this layer issue appeared if you happened to be an Android based user if you could access someone with an Apple based device and then loaded there glitched town on that it would fix the problem but as this time it appears to be affecting both device types I don't know if loading up on the opposite device type would help, sorry I've not been more helpful and hopefully someone has seen or knows something that I don't and can point you towards a fix.


  • AAADave1961
    114 posts Member
    edited January 2016
    krayzjoe wrote:
    Ever since an update in Dec, my layering in my town is messed up. Uninstalled, reinstalled, ya-da-ya-daya-da. Now with the new update, my layering issues have not been resolved. Any suggestions, other than giving up the game... ?

    I remember similar posts, but can't find them, and I've received no response on the Bugs and Issue Forum. Any suggestions would be helpful! Thanks!

    Not sure what doing 'ya-da-ya-daya-da' is :wink: but please list ALL of the things that you've tried when asking for help or you'll get a lot of answers with things you've already done (like the things I'm going to suggest).

    First, I tried to look at the FB picture you posted but it's not working for me. Privacy settings maybe.
    So I can't really see what the issue is. Could you please post the image on another site or describe what is happening in detail?

    What device and OS version you're using, this is important information as it could be a problem with your specific device and/or OS version. Always post this when asking for help please.

    Did you open up the task menu, close the game and the turn your device off and back on?

    Did you play the game on a friends device? You can play your game on another device even if the OS and device type are different (iOS/Android/iPhone/etc.). If the problem DOES NOT occur on the other device then it is something going on with your device or OS (or both) and should be reported to EA customer service with very specific details.

    If you're using an Android device, it could be some other App that is installed messing things up. Not likely but it can happen. This usually isn't the case with iOS as Apple keeps their stuff locked down more.

    Those are the only things I can think of off the top of my head. I hope my suggestions help. Please keep us informed as to how this works out for you.

  • TwigletStyx
    1043 posts Member
    edited January 2016
    Here's a link to the most recent thread regarding this issue (with a couple of *possible* fixes):


    Best of luck.
    Lately It Occurs To Me... What A Long Strange Trip It’s Been.
  • krayzjoe
    16 posts
    edited January 2016

    I tried a few of the suggestions from here and the link: No luck!

    I installed the game on my wife's phone and the layering glitch is still there.

    On my phone, I uninstalled and reinstalled, powered on/off in between.

    I am going to try it on an IPad. I use a Samsung Galaxy SIII, Android Version 4.3

    I haven't posted anything to FB.

    Should I contact EA? Last time they seemed pretty uninterested in helping. :(
  • kellinadyer
    63 posts Member
    edited January 2016
    Let us know if the Ipad works.... i also have the hated layering glitch and am at my wits end. If it works on a different device, I'm gonna have to try and find an android phone.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.