EA Forums - Banner

Running so slow!!!!!

Replies

  • I'm going to try disconnecting the injury 500 pieces as at the moment the game is practically impossible to play. Still peeved off about the stupid land tokens too as apposed to buying the land with our billions of game money.
  • Good luck with TRYING too disconnect the injury 500 tracks!! It took me ages to get them move it just not respond at all ! The only thing that worked was first put them in store.
    Man what a bummer ! And my iPad is working just fine for me .
    If EA will buy me a new one , feel free !!!!!!!
  • Well ive contacted ea about the slowness and freezing and have had to laugh because they tried saying it was my devices slowing down my springfield and not the game if it was the game they would have heard about it before but from the looks of the posts its been reported god knows how many times
  • Willy9292
    1664 posts Member
    simpsonare wrote: »
    @pigginlove662 it is your devices capability.

    There is some truth to this as @simpsonare states. I have tried the same 2 towns on a Galaxy S7 and a S5 and there is a very noticeable difference. The S5 has to have the tracks disconnected to be usable. The S7 is fine with race track and log ride running. Hopefully the anticipated option to turn of the animations will resolve this.
    Unsolicited friends requests are all denied.Please PM me.
  • simpsonare
    2321 posts Member
    Willy9292 wrote: »
    simpsonare wrote: »
    @pigginlove662 it is your devices capability.

    There is some truth to this as @simpsonare states. I have tried the same 2 towns on a Galaxy S7 and a S5 and there is a very noticeable difference. The S5 has to have the tracks disconnected to be usable. The S7 is fine with race track and log ride running. Hopefully the anticipated option to turn of the animations will resolve this.

    Both of my rides running causes the characters to have a little bit of a glitchy walk on the note 8.
  • I agree extreme slowness and lag since injury 500 was released. I have a new g6, guess you need a flag ship device just to run this **** game. I may just have to give it up after 5 years.
  • I am playing on a Samsung S8 plus and I am not facing lagging. But if I was to put out a group storage, I need to wait like 2 - 3 seconds for it to be done.
  • Willy9292
    1664 posts Member
    I agree extreme slowness and lag since injury 500 was released. I have a new g6, guess you need a flag ship device just to run this **** game. I may just have to give it up after 5 years.

    Have you disconnected the track on the Injury 500. This has been noted by most as the solution as it stops the animation until we get a switch.
    Unsolicited friends requests are all denied.Please PM me.
  • I had the same question as everyone else. But I am not sure so i will just ask. So if you have way too many things out in your Springfield like all of the decorations, houses, buildings, and also all the tracks I had a warning about too many objects and may cause the game to run slow. So i been removing stuff and still the game is running really slow. So has anyone else been having the same issue?
  • This is my humble opinion regarding the slow down.

    I started playing this crazy game at Christmas 2012 with my new iPad 3. Years later, the crashing, slow downs etc. (including no more updates with the iPad) were getting ridiculous. Per recommendations from other posters I removed the monorail (but still generate rails for the donuts) and started deleting apps, pictures, videos, music to free up more storage which helped for the short time. Every update the slow downs/crashes got worse. I play 4 towns. My main town was the worst. (I have never reached the decorations limit), but I also saw the same thing in my 4th town which has very limited land, decorations, characters, buildings.

    So I bought a new iPad Pro a month ago. Wow! What a difference. More memory, more RAM and pretty much no more crashes. One thing I did notice though is that if I have other apps open when I play this crazy addicting game, I will see a slow down in one area of my town. Usually around my Stonecutters and it’s in all 4 towns. Sometimes I will sync the game and hard close it. When I then go back in to the game it is sometimes better and other times no difference- server capacity/usage?

    The game is huge. Server capacity needs to be huge too. RAM and storage need to be available for the game to function optimally. I don’t think EA expected this game to go on this long. I never thought that I would play it this long either!

    Just my 2 cents. :smile:
  • Willy9292
    1664 posts Member
    I had the same question as everyone else. But I am not sure so i will just ask. So if you have way too many things out in your Springfield like all of the decorations, houses, buildings, and also all the tracks I had a warning about too many objects and may cause the game to run slow. So i been removing stuff and still the game is running really slow. So has anyone else been having the same issue?

    Suggest you read the post before yours about disconnecting the track/chute on the track and log ride. And yes tons of people are having issues with it.
    Unsolicited friends requests are all denied.Please PM me.
  • 168sean168 wrote: »
    I am playing on a Samsung S8 plus and I am not facing lagging. But if I was to put out a group storage, I need to wait like 2 - 3 seconds for it to be done.

    its normal it has to store all items and calculate each one 's position
    My Youtube and Twitch / WikiSimpons Current Event Page and Discord
  • Jonalinn
    1805 posts Member
    Well since the prize track 3 update, my game is excruciatingly slow :/
    You got a great looking town~168sean... Checked out your town, WOW! ~daved
  • Just lost access to the game... Bart Screen... Toronto, Canada... 3:30pm..Eastern time...
  • oubouncer wrote: »
    Why did EA combine Springfield and Kristy land?!?!?! Can't remember the last time tsto ran so slow!!!! :(

    Totally agree how about it barely runs at all
  • Jonalinn wrote: »
    Well since the prize track 3 update, my game is excruciatingly slow :/

    Did you remember to disconnect 1 piece of the Zoominator? The 1st group of pieces you get from the prizetrack has the tracks all connected. My game was running slow until I disconnected one track.
  • rgb1091
    1 posts New member
    I'm at level 149 and when they destroyed Krustyland and gave us Itchy and Scratchy land it slowed down the whole game . I found if you disconnect the track on injury 500 and the log ride the game runs perfect ! they need to update this app soon !!
  • Mine is unplayable. I'll try to disconnect the zoominator.
  • That worked! Thanks not sure why I didn't think of that.
    It's back to normal slow now again... Lol
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.