EA Forums - Banner

Can’t log in

posts New member
I keep getting a message to enter a verification code, and I do and it tells me that if I complete a profile, I can play on multiple devices, then when I click continue, it doesn’t let me log in. I also don’t get instructions on how to complete the profile. How do I log back in?


  • I have been having the same problem it gives me verification code I enter same then it says to Ck email to complete profile then nothing.
  • Same thing for me. I haven’t been able to log in for 3 days. I have tried deleting the app and re-installing and that doesn’t work either
  • CapnInssano
    4 posts New member
    Same thing, reinstalled and went through the process 10 times Atleast. Frustrating.
  • CapnInssano
    4 posts New member
    Got logged in!!!! Don’t shut your game down and check your email, send the code and check it on another device while the game stays open. Input code and it logged me in. Hope that helps!
  • 11EEvey
    2847 posts Member
    Check out these tips from EA: https://forums.ea.com/en/the-simpsons-tapped-out/discussion/271978/email-verification-tips#latest
    Tip from Deadshot DCU: Force close out all apps, restart device. Now open up the game, log in with the code and you should be ok.
    Add your me too here: https://answers.ea.com/t5/The-Simpsons-Tapped-Out/Code-Issues-Can-t-log-into-the-game/m-p/10362308#M135023
    contact EA for help: https://help.ea.com/en/contact-us/new/?product=the-simpsons-tapped-out
    chat or phone is best during US Central time business hours M-F
    or try them on Twitter https://twitter.com/EAHelp
  • oranges
    25 posts Member
    Still can’t log in, even with the right code. Hope this gets fixed.
  • MYA1364
    4 posts New member
    I Got In!!!! I Play on Bluestacks for about 4 years and i was stuck on the loading page after the new update, There is Something wrong with the new Update! I used the disk cleanup from user data section of the program's settings options. it's like clearing the cache or game data. Try it out guys, Hope it helps!
  • oranges
    25 posts Member
    Even with the new update, it still tells me that the code is incorrect when I typed in the right one. It’s just a waste of time.
  • zensmom01
    1 posts New member
    I have 2 accounts. One on an android tablet, which I can access, the other on an android phone that I haven't been able to login to since June 8. Tried on line chat and Tipasha, the agent I was stuck with, was absolutely useless. I then called and spoke with an awesome fellow, can't remember his name, but he helped me change my email address and password since I no longer had access to the old email. However, I wasn't getting the verification code. He said it could take a couple of hours for the reset and to try later. Well, that didn't work. I called again a couple of days later and reached another awesome agent. He verified my account, but even checking on a separate device, I'm STILL not receiving a code. He said about 20% of all users are having this issue, and to keep trying. Spoke with another great agent in Texas on the 17th. He also tried to help me get into my game with no luck. Keep in mind, I check for updates, clear my phone and try to log in several times a day. On the 23rd, I love inflicting pain on myself, so I called again. Agent in Europe was absolutely useless. Told me to check Twitter, Facebook, Instagram and the Forums for any updates. Told him I didn't have those accounts and asked for the URL for the forum. He actually told me to Google it!! Anyway, it's been almost 3 weeks and still not into the game. I'm not tech savvy, but really.....why is it taking so long with no work around? And I'm missing out on the current quest! Anyone else been out this long??
  • Same here and they just give useless hints like „check out this community“ - IMHO they give a s***.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.