EA Forums - Banner

The "I've Lost My Springfield" Thread


  • acebrooker
    69 posts
    edited December 2012
    @mattodare just better not reset on me again! (I saw your request wouldnt let me add you so I send you one.)

    So people out there that lose your town. There might be a chance they can get it back, but if you be persistent and contact them and not these forums you might some something back out of it.
  • Deatheller
    107 posts
    edited December 2012
    Now this may be a dumb reply/solution, but that happened to me once and i about flipped *, come to find out i wasn't logged into my account with Origin so it started a whole new game as a guest, to fix it i just powered off my phone then back on and then it prompted me to either log into Origin or start as a guest. Yet again may or may not be the cause for you guys, but just check and make sure.. could just be a simple over look, or perhaps it's something all together different but thought id try and help :-)
  • Nicolasmp_7_5
    6 posts
    edited December 2012
    My city was deleted for the third time this month I contacted EA Support by phone and e-mail ( 04 81 68 08 08 ) and they told me to Login / Log out, reinstall the game or try to play offline (...) I lost all my doughnuts and in game purchases i'm a huge fan of The Simpsons and i'm very disappointed and sad how EA handle this situation.

    Id: Nicolasmp_7_5 / iPhone 5 (ios 6.0.2)

    EA Customer service e-mail:


    In game snapshot:






  • mattodare
    23 posts
    edited December 2012
    @acebrooker dude, sorted add, I'd maxed out on contacts. Kicked to the curb some waster towns to make room :)
  • periley_0
    1 posts
    edited December 2012
    Anyone heard anything yet about current issue with rest to lvl 1?
  • Reakelly
    2 posts
    edited December 2012
    My game reset to level 1 4/5 days ago tried logging out and reinstalling still not got it back :(
  • winstonwah14
    1 posts
    edited January 2013
    my game just got restarted to lvl 1 and i'm pretty upset about that. after days of saving up to almost 700 christmas coins and trying my best to get myself up to level 21.. all my efforts gone down the drain, with the game restarting..
  • megapasseu
    34 posts
    edited January 2013

    Do you need friends or want users to add you fastly, so go there and post your id! :


  • baddoc75
    15 posts
    edited January 2013
    Same problem. My Spingfield reset to level 1 a week ago. Tried to contact EA via the support site. Never even got a response from their side.
  • Glock23D
    142 posts
    edited January 2013
    My city was deleted for the third time this month I contacted EA Support by phone and e-mail ( 04 81 68 08 08 ) and they told me to Login / Log out, reinstall the game or try to play offline (...) I lost all my doughnuts and in game purchases i'm a huge fan of The Simpsons and i'm very disappointed and sad how EA handle this situation.

    Id: Nicolasmp_7_5 / iPhone 5 (ios 6.0.2)

    EA Customer service e-mail:


    In game snapshot:






    Stop posting here, u are loosing your time, admins do NOT check the forum.
    Quoted to show images.
  • edited March 2013
    I'm so angry I'm level 26 have build up my Springfield over months and months spent money on donuts now it won't load up !! Origin EA sort the issue, your providing a service that isn't it for purpose people are spending money then loosing what they've paid for !! I want my Springfield back or a full refund !! NOW
  • JonasBM22
    1 posts
    edited March 2013
    just now, I changed my Origin account username. After doing so, my Simpsons tapped out account would always say there is a level 1 springfield already on this device. and what ever i do. i can't recover my level 18 springfield. please help me. :cry:
  • SplicerReilly
    6 posts
    edited April 2013

    I lost my world when i changed my origin ID. when i logged in to tapped out it asked if this is my lvl 5 world. The lvl 5 world that is showed me is a world that was on my phone that was not bound to an account, it was an anonymous world. I could never get my high lvl world to be found but i was still getting notifications from it.

    So i went to gmail and created a new garbage email address. I then went in game and continued playing this anonymous game. From this game i then went to add a friend. It prompts you for your email. attach the garbage email you just made to this world. When it was successfully bound to this email. I logged out, then logged back in to my main email and it was there!

    Hopefully it shows up, it worked for me.
    i need more friends in game too, so if this works for you add me, SplicerReilly.

    Create a junk email address from gmail or whatever
    Go into tapped out
    log out of whatever account you are in.
    Play an anonymous game
    The game that shows up is hopefully the low lvl game that they are trying to replace your main account with
    play this game until you can add friends
    It will prompt you to attach an email to it
    Enter the junk email you created, play for a few seconds more to make sure it is connected properly
    Log out and then log back in to your main account.

    Post edited by Unknown User on
  • jklaich
    4 posts Member
    edited April 2013
    I've had on at least 3 different occasions where numerous buildings have vanished. Right now is one of them.
  • kathystites
    4 posts
    edited April 2013
    this game has been out for over a year now and it still has many of the same problems.
    today i lost everything i have done over the past couple of months in my android version of tapped out. it was all working fine yesterday but today when i logged in it went all the way back to the original screen and started from the beginning.
    i'm tired of this.
    no more
  • idrive911770
    19 posts
    edited June 2013
    A friend of mine who doesn't have an origin account just lost his game. all the snake wacking stuff, heaps of doughnuts, hours of work. all gone. he'd like to say <sarcasm>thanks EA</sarcasm>

  • 10011137
    36 posts
    edited July 2013
    My town just dissapeared. I had like everything...

    Haven't played for like a week, logged in now and it's the starting screen with Springfield blowing up and then level 1.

    And I can't log out. Then I get the "man I hate this screen" screen.

    My GameID is the same as my name here..

  • dorianlong
    1 posts
    edited August 2013
    my wife had the same problem so i logged into her account on my iphone and it was all there. when she tried to log into hers again on her iphone (while i was still in her account and with it open) it told her she had to save it on the other device before she could play... i then logged out of mine and tried hers again and hey presto it was working again... i REALLY hope this works for other people... good luck!
  • pds30
    7 posts
    edited August 2013
    I cant get on my Springfield it keeps saying "there is a level 1 town on your device is this your Springfield?" but my level 32 town won't load up.
    Just looked on my sons Springfield and its their under some one else's name.
    The name is "gregorypaj26"

    Is there any thing that can be done to get my Springfield back please??? I have been playing for about 2 1/2 years
    Now and have a massive Springfield with quite a few of the premium items and characters.
    Also I'm still getting the notifications for my town but it still won't load it even if I open the notification it still says the same thing.
  • winniezz886
    4 posts
    edited August 2013
    say goodbye to your town, EA totally don't care
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.