EA Forums - Banner
CLOSURE ANNOUNCEMENT: The TSTO forums will be closed on December 13th, 2023. Read more about the future of the forums here.

Issue: Accessing Wrong Town After 1/14/14 Update


  • bengz89
    8 posts
    edited January 2014
    When logging I'm being taken to a random town which isn't my own. My id is correct and even the friends list is correct. But it's not my town. What's going on
  • bengz89
    8 posts
    edited January 2014
    Loading someone else's town. Can't retrieve my own.

    ID: bengz28

    Mayhem id: 16779218646629079718514608562001397315
  • DerJon01
    4 posts
    edited January 2014
    I had been in contact with EA about this before it became widespread as I had noticed that my town was different, depending on if I logged in on Android or iOS. iOS was my original, Android was this seemingly random town. This morning, I woke up having received this message:
    Thank you for writing back to us at Electronic Arts.

    I've have checked your account under Origin ID 'derjon01' and can see that your current level in the game is 37. Please be assured your Springfield is not lost and we will help you to log into your account again.

    As you told us that you can get into the game with iOS device but not with Android device so I would like to inform you that this could be a temporary issue which will be fixed soon with the next update. However, if you are facing difficulty while trying to access your Springfield on both platforms then please let me know by updating the current case #11268550

    I hope that all your questions have been answered. However if you have any further query please feel free to contact us anytime. For quick access to EA product specific FAQ’s please visit our online knowledge base at: http://help.ea.com/

    So I wrote back saying that the issue has spread to my iOS device as well. BUT, if you look at their message, you can see (maybe I'm just optimistic, but...) that they are working on an update to address this situation. Hopefully this all gets straightened out soon!

    Good luck, everyone out there!
  • fireboltfloo121
    6 posts Member
    edited January 2014
    Please please fix my town! Level 37! Premium purchases! All of Christmas stuff! All gone. Now level 13 in a town that is not mine!!!
    Please please fix! I cannot give my correct town mayhem id, I only have mayhem id of incorrect town. Please EA fix this!
    Playing on iPad and iPhone.

    User: fireboltfloo121
    Mayhem ID (incorrect town):22183840756944608319135207488804014581

    Annoying, now I cannot even login to my old/wrong town. Getting password wrong error!
  • Rdc-936063
    7 posts
    edited January 2014
    I can't login on iphone5 and ipad2.
    username: RDC-936063.
  • bugliam
    1 posts Member
    edited January 2014
    Lost my town :(
    Worked for a year to get to level 37. Please help!
    Playing on iPhone 5.
  • Jlast619
    1 posts
    edited January 2014
    I did update last night and loaded different town. I deleted app and reinstalled this morning. I am now in my old Christmas town.

    User. Jlast619
    Version. 4.6.1
    Mayhem id. 17903909127055882378416296890617173562
  • edited January 2014
    Did anyone got response when posting username and mayhem id?
  • robe148
    5 posts
    edited January 2014
    When I logged on it is not my town, it is organized different and at a different level, I don't have all the characters I used to have either.
    I am playing on iPad 4
    Username is robe148
    Mayhem id#: 24875961061578813291457663760405877246
    I'm unsure if this is my mayhem I'd because I found it in the town that is not mine. Please help! I was playing for so long and building up my donuts and money. Please give me my old town back.
  • stereoblab
    4 posts
    edited January 2014
    It looks as though they are working on individual account issues in a thread at answers.ea.com, which is where I was directed after e-mailing EA.
    Just a quick update: We already fixed several towns. wish4wonderland, guntr1p, lmh731, and robertuybrush verified in this thread that they can see their original town again. I checked, they are indeed on the list of the accounts we fixed.

    We will keep fixing the accounts you report here. There is no need to create an additional ticket at help.ea.com in these cases. As long as you report your case here, you should get help.

    I'll give you another update once we fixed another batch of towns.
    -- eaursula, Community Manager

  • stephlee0606
    1 posts
    edited January 2014
    My town has also been replaced! I'm using iPad ios7.0
    Mayhem ID:19947796931059892153164034275886449641
  • Susan7782
    5 posts
    edited January 2014
    Same issue. Lost my level 37 town, replaced with a level 4 town.

    Using iPhone 5 ios 7.0.4
  • mstrox
    4 posts
    edited January 2014
    nevermind - thanks
  • medic9114fun
    3 posts
    edited January 2014
    Logged in after update and not my town.
    Mine was level 37 town and had over 120 donuts

    My id should be medic9114fun

    Now it's 27455561351568969895130278236677981447

    I've tried all the log out restart stuff and still wrong town
  • turboearl535
    1 posts
    edited January 2014
    please fix mine too..

    ID turboearl535

    mayhem# 62069222509233906285824245911754135658
  • idacavalier
    4 posts
    edited January 2014
    loading someone else town :shock: help !

    iphone 4s

    level 37

    mayhem id (my town) 68787340644772021509977860864935447285

    username :idacavalier
  • IsamuSushi13
    2 posts
    edited January 2014
    I have the same problem after the 1/14/14 update. I deleted the app re-downloaded it and ran without the update and my town was back to normal (w/snow). Going to reset my device before updating and trying again, but I'm not getting hopes up :x
  • potta2012
    6 posts
    edited January 2014
    My town n level have stayed the same bt i have downloaded update but there is no new quests etc to carry on with the game
  • tfrnk
    60 posts New member
    edited January 2014
    DLed update on iPad, same issue; redirecting to wrong town. Logged in, logged out, restarted device...no such luck. Although I haven't played on my iPhone for a few months, I was able to access my town on it as I did not install the 01/14/14 update.

    Here is the ID you requested: 16041667892055164431859453383417871443 - please note this ID is from my town, not the one I'm being redirected to.

    I intend on playing solely on my iPhone until issue has been resolved so that I may return to my iPad.

    Please let me know if you need further information....I will be happy to provide it....
  • cathyfitz245
    43 posts
    edited January 2014
    After updating from the Xmas Event, on 1/14 at approx. 6:00pm CST, I continually access the same WRONG town.

    I originally accessed from my iPhone 5, with latest IOS 7, but other Apple devices (including iPad 4) get same wrong town. Can view my correct town, by visiting only, from friend's iPad.

    I have uninstalled/reinstalled multiple times, hard reset iPhone, logged in/out multiple times, tried logging in from other devices multiple times.

    My login id is: Cathyfitz245
    the mayhem id that I am currently seeing when accessing the wrong town: 16923756483431965030488443010211646929
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.