EA Forums - Banner
CLOSURE ANNOUNCEMENT: The TSTO forums will be closed on December 13th, 2023. Read more about the future of the forums here.

Issue: Accessing Wrong Town After 1/14/14 Update


  • danx1260
    21 posts
    edited January 2014
    Can't access my town since updating. Playing on an iphone4 and Kindle Fire. My Mayhem ID is 15524137034461644829730418668923795116
  • tulrich2702
    4 posts
    edited January 2014
    I feel like ea is ignoring me. I sent a support email as soon as the update went out and sent them all my info. They said they were escalating my issue to higher department. No email from them in over a day and I'm still logging into a level 14 town when it should be a level 37 town. Playing on an iphone 5 and an ipad 4. Mayhem ID: 31877978589142665317214653717409988853
  • NikeNate
    1 posts
    edited January 2014
    Same problem here. I have done everything trying to fix it.
    Mayhem Id: 16469856889231394719830367338182963894
    Iphone 5s
  • brett2311
    3 posts Member
    edited January 2014
    Same problem with having the wrong town.
    User name Brett2311
    iOS 7.0.3

    Mayham id 13708541625572122375702119643841541927
  • dmbarb993
    1 posts
    edited January 2014
    I'm also having the same issue.. different town since the update. :cry:

    I'm playing on an iPhone 4S. My origins name is dmbarb993. My mayhem ID (for the wrong town, I don't know how to get it for my real town) is 61688188761994334080052335616237364379

  • kivalo21
    27 posts
    edited January 2014
    Post edited by Unknown User on
  • efullerjef30
    1 posts
    edited January 2014
    My town is gone! what is going on? I tried logging out, closing the game, rebooting my ipad 4 with ios 7, relaunching the game and signing back in and it's a level 1 town!!!! I had a level 37 town!!!

    On which device are you playing? ipad 4
    Are you using iOS or Android? (Please name the OS version.) Latest IOS
    Are you playing with Origin login or anonymously? Origin login
    Are you posting with the Origin account you are playing with? If not, what is your Origin ID? I'm assuming this is my origin account. efullerjef30 appears to be my account.
  • twinmum1987
    14 posts
    edited January 2014
    vetteeater wrote:
    I got my town back!!!!!!!!! All I did was post in this thread. Good luck all!
    Bit ridiculous that emails to support are not being responded to, they expect you to sign up to yet another forum to get their mess up rectified ....
  • edited January 2014
    Update: To everyone that has complained on here I think EA is responding slowly, but surely to everyone. I had problems with my account since the update (not logging into the right town), but as of right now 1:59am CST my town is completely fixed! The layout is restored, buildings, content, money, donuts etc. Everything has been fixed! Thank the Gods! I was really bummed about losing my saved up cash and donuts and content, so so glad that EA addressed these problems and fixed it. If they haven't fixed yours yet, wait it out! Also, post on the EA forums link that was posted here as well. Good luck guys!
  • lynncinnamon
    10 posts
    edited January 2014

    Can't load my town at all. Everytime I try, the app closes. Very frustrating.

    UN: lynncinnamon
  • edited January 2014
    Updated on 01/14/14 and told me I needed to log into my "other device" and continued even though I don't play on any other device and it signed me into an entirely different town. I've tried logging in multiple times throughout the day, restarting the device and logging in, and even deleted the game and downloading it again and it's still coming up with the same random town.

    I have a non-updated iPhone 4S.
    Mayhem # 24259257268900289112954105638251226733 was on the account I was logged into and
    my origin ID: britt_bratt3663

    Please fix this! I don't want to lose everything! =(
  • gigges91
    2 posts
    edited January 2014
    Got the same problem with the new update,
    same ID I post here,
    Ipad Mini with latest version of IOS and Moto G with Android 4.3
    I play logged in in origin
  • Contie
    1 posts
    edited January 2014
    The same issue applies to me, on both my iPad2 and iPhone 5. I was level 37, now 11.

    origin Id: Contie73
    Mayhem ID:31459056525786537337842501901464460406

    Initially the problem was with my ipad version post update, but my iPhone version was ok, not updated. I've tried signing out of origin and deleting the app from my iPad, powering off and reinstalling, but no joy.
  • edited January 2014
    Lost all my town was Lv37 now 14 on iPhone 5 but my iPad 4 my town still correct with out the update still snow on the ground

    Id theevilkanoofy

  • kivalo21
    27 posts
    edited January 2014
    Got my town back.

    Deleted game from my phone and reinstalled it. It reverted back to Christmas update, but at least my town is still intact. If Homer melted down the New Springfield again I would have walked away...

    EDIT: Nevermind, it just forced me to update
    Post edited by Unknown User on
  • DerJon01
    4 posts
    edited January 2014
    They seem to be fixing this on a case by case basis in the forums over at help.ea.com
    Mine is fixed and updated.

    Good luck to the rest of you!
  • corona_baby
    3 posts
    edited January 2014
    I updated and all was good. Had to restart my iPad and then it stopped crashing but I've noticed that as per the update stated there would be new quests but I don't have the new quests. Any one else got this problem?

    Origin ID: corona_baby
    Mayhem ID: 14527648552753960652648245482106925347
  • Donna4612
    369 posts Member
    edited January 2014
    Everything was going well and then I got a Bart screen saying something about maintenance issues. I can log into my main town and my feeder town, but my handicapped sister's town opens with my feeder town.

    I closed the app. Rebooted my IPAD 4, but cannot open to my sister's town.

    feeder town: jangey
    mayhem ID: 11555080231614495902894851159516762624

    Sister's town: Carol1238
    shows jangey's mayhem ID

    Thanks for any help to resolve the issue.

    Update 1/17: Carol1238 still opens with jangey's town.

    Update 11/21: I deleted the app and reloaded. Rebooted my IPad and now have my Carol Springfield back.
    Post edited by Unknown User on
  • mcmexico
    9 posts
    edited January 2014
    using an Iphone 5

    my game went back to the start I am a level 37 with a lot of donuts and cash

    My mayhem Id is


    origin id mcmexico
  • boyjonker15
    1 posts
    edited January 2014
    Hey guys,

    After the update from christmas to normall ive lost everything 16-01-2014, coming in a springfield with lvl 11, but im level 37 normally. Before the update everything went normall..

    Playing on ipad3

    Please help me getting my springfield back :(

This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.