EA Forums - Banner
CLOSURE ANNOUNCEMENT: The TSTO forums will be closed on December 13th, 2023. Read more about the future of the forums here.

can't connect?



  • nabocough
    45 posts Member
    edited June 2014
    Me neither. It went down before I could download the update and see what this fuss is all about too. :(
  • crosby357
    3051 posts Member
    edited June 2014
    Just got back in.
  • davenavarr90
    2 posts
    edited June 2014
    Yuuuuuuuuuup I'm in the same exact boat, it's bad enough I'm running out of time to collect more parchments to get all the items, but then add this delay to the mix doesn't make it any better :/.
  • DHW4Real
    1 posts
    edited June 2014
    I had a suspicion this wasn't only my problem. Cell phone puttered out two different times while tapping through my friends' Springfields, and after the second time, got the message that I was logged in on another device. Now can't connect to the server. Crossing my fingers that I don't lose 41 levels of progress, but I do understand. Will try not to do something stupid to erase my town in the meantime!
  • edited June 2014
    Not only is it down right now for me too, but when I tried to post in here and complain about it, it sure made things unnecessarily difficult! There's some sort of "default identity selector" thing where it will give you the option to be an associated xbox live gamer tag, or command and conquer .com, or a bunch of other random things you might have linked to your EA account... Uh, I guess that'd be cool, if it didn't totally non-obviously break other functionality? If you select anything other than "EA ID", it'll tell you at the top of the forum pages that you're logged in but you can't post because your email address is unverified. Until you switch it to EA ID (which is the same username as my live gamertag in my case so the difference isn't even visible), and then it magically knows I've verified the email on my account. That it already knew I was logged in as.
    Good times, thanks EA.
  • neuroheart
    8132 posts Member
    edited June 2014
    Hope the last Number 1 task today is shorter than 6 hours, or I'm boned

    my last task was only one hour
    Mine, too.
  • Samaranth01
    2187 posts Member
    edited June 2014
    Finally got back in. :-)
  • rolybert7
    2776 posts Member
    edited June 2014
    Has anyone else noticed that the message that came up after you drove away all the brothers is gone?

    I just spent several minutes in my town looking for one last one and there wasn't one!

    Never mind I found the last one and got the message!
  • neuroheart
    8132 posts Member
    edited June 2014
    I got back in, but then it crashed. *sigh*
  • lee67628
    818 posts Member
    edited June 2014
    It's restored.

    How I wish we can get free donuts from each downtime? :roll:
    TSTO Completionist since 2012
  • LilJonny64
    74 posts Member
    edited June 2014
    Im worse than down time right now. It logged me out and apparently lost my entire account. It wont recognize me no matter how many times I reset my password. :(
  • spidergirl79
    499 posts Member
    edited June 2014
    I got back in! Yay! Got my Ark of the Stonecovenent. ^^
  • edited June 2014
    Anyone else currently having trouble? I've been trying for about 2 hours now
  • illislune
    177 posts Member
    edited June 2014
    I had the server down message twice, before being connected the third time. Just after I had managed to send a high roller to donate to charity, I lost my connection again. Hopefully I'll be able to login again in time later today to still get the 400 emblem #1 task in time.
  • quickstrike8
    36 posts Member
    edited June 2014
    I get in, it throws me right out.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.